Force Installing - Application cannot be safely installed on your environment

Hi

I want to install a component from the Forge (In-App Notifications Web) but when I do, it gives me the following warning message and gives me just a 'Force Install' option. I would like to know why it is doing this, how I can resolve it, or if I can't resolve it, what are the dangers?

Thanks in advance for the help!

As it says in the dependencies at the bottom, it requires Silk UI Web version 3.1.8.  Do you have this installed and which version? 

ChrisRE wrote:

As it says in the dependencies at the bottom, it requires Silk UI Web version 3.1.8.  Do you have this installed and which version? 

 Hi Chris

Thanks for the response. I currently have Version 4.1.1 installed - which is obviously later than 3.1.8 - so this component must have been created before the latest upgrades.

What is the best way around this then?

Solution

Whenever I get this from a forge component that has a dependency on an older version of silkui I generally just install it and then go in and manually refresh references and republish. 9 times out of 10 that works perfectly fine. If something actually does have a reference incompatibility then I just fix it manually and republish.


Solution

I agreed with Jeanene.  The Forge app is just saying that the it's written for SilkUI Web version 3.1.8. It's more than likely that version 4.1.1 works fine, but you don't really know what features were added/removed/changed that may break the app as it's downloaded from the Forge.  Therefore, force install it, check/refresh dependencies, and you may or may not need to make some extra accommodations.

Jeanene Williams wrote:

Whenever I get this from a forge component that has a dependency on an older version of silkui I generally just install it and then go in and manually refresh references and republish. 9 times out of 10 that works perfectly fine. If something actually does have a reference incompatibility then I just fix it manually and republish.


 Hi Jeanene

Thanks very much for your response. I feel more comfortable now to Force Install if necessary.