[Google AdMob Plugin] IsTesting = False >>> Not showing

Forge Component
(6)
Published on 14 Aug by Miguel 'Kelter' Antunes
6 votes
Published on 14 Aug by Miguel 'Kelter' Antunes

Hi there!
I'm having an issue with the ads

As soon as I set the IsTesting property to False, the ads are not displayed.

I think I've configured this the right way but I'll share to give you info:

Extensibility Configurations:

{

    "plugin": {

        "url": "https://github.com/kelter-antunes/cordova-plugin-admob-free.git#v0.18.1",

        "variables": [

            {

                "name": "APP_ID_ANDROID",

                "value": "ca-app-pub-507580662XXXXXXX~5576XXXXXX"

            },

            {

                "name": "APP_ID_IOS",

                "value": "ca-app-pub-507580662XXXXXXX~2178XXXXX"

            }

        ]

    }


}


OnApplicationReady


The configs have the codes set as well.


At the desired screen the OnIniltialize calls the Banner_show action.


_______


Result:

While IsTesting = True, everything works as it should, the banners appear, even the interstitials as well.

But when I change the IsTesting = False, the banner and interstitials don't appear. I debuged and every thing runs smooth, no exceptions, equally to the path followed when the IsTesting = True.

I tried many approachs, all of them with sucess while IsTesting=True, but none of them while IsTesting=False.

Can you help me? :)





Hi,

What is the error message? 

In the  'Banner_LOAD_FAIL - Error: 0 Reason: Internal Error', it suggests to check the Google AdMob Test Ad Ids.

Swatantra Kumar wrote:

Hi,

What is the error message? 

In the  'Banner_LOAD_FAIL - Error: 0 Reason: Internal Error', it suggests to check the Google AdMob Test Ad Ids.

 

 Hi Swatantra Kumar


I have no error, the only difference from working to not working is purely the isTesting changing between True or False, when True the test ad shows, when False, no ad appears, no errors .