122
Views
6
Comments
Solved
Timer issue urgent
Question

@All,

since yesterday after the latest security update (10.0.1104.0) on our production environment, our OutSystems Timers don't work anymore.

After about 133 seconds we retrieve an error (see below) and the timers starts again for 2 times.
Last friday these timers worked perfectly.
We very need your assistance.

Best regards,

Jeroen Vormer



Error detail

Id:

28248a47-575d-49d5-a895-1cd9f17011a0

Time of Log:

13-09-2020 13:23:45

eSpace:

Monitoring

Tenant:

Users

User:


Session Id:


Server:

xxxxxxxxxxxxxx

Module:

Scheduler

Message:

Scheduler Service: Error executing request http://127.0.0.1/Monitoring/_TimerHandler.asmx for Timer MonitoringProcessNewStedin. Request duration = 105 secs.  [retry 4 of 3 scheduled]

Environment InformationeSpaceVer: 0 (Id=0, PubId=0, CompiledWith=10.0.1104.0)
RequestUrl: (Method: )
AppDomain: Scheduler.exe
Path: C:\...\PS\
Locale:
DateFormat: yyyy-M-d
PID: 8016 ('Scheduler', Started='9/13/2020 1:06:55 PM', Priv=65Mb, Virt=663Mb)
TID: 24
Thread Name: Timer Processor #5
.NET: 4.0.30319.42000

Stack:

[1] The underlying connection was closed: An unexpected error occurred on a receive.
at System.Web.Services.Protocols.WebClientProtocol.GetWebResponse(WebRequest request)
at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
at OutSystems.HubEdition.Scheduler.TimerHandler.ExecuteTimer(String ssKey, Int32 timeout, Int32 tenantId)
at OutSystems.HubEdition.Scheduler.TimerJob.<Execute>b__22_0()
at OutSystems.HubEdition.ServerCommon.SandboxUtils.ExecuteForSingleSandbox(String sandboxToExecute, Action action)
at OutSystems.HubEdition.Scheduler.SchedulerProducerConsumer`1.<>c__DisplayClass25_0.<Execute>b__0()

[2] Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host.
at System.Net.Sockets.NetworkStream.Read(Byte[] buffer, Int32 offset, Int32 size)
at System.Net.PooledStream.Read(Byte[] buffer, Int32 offset, Int32 size)
at System.Net.Connection.SyncRead(HttpWebRequest request, Boolean userRetrievedStream, Boolean probeRead)

[3] An existing connection was forcibly closed by the remote host
   at System.Net.Sockets.NetworkStream.Read(Byte[] buffer, Int32 offset, Int32 size)

Rank: #150
Solution

Issue solved by editing the recycling settings. In our case the Virtual memory was checked instead of the Private memory.


Best regards,


Jeroen

mvp_badge
MVP
Rank: #133

Hello Jeroen, 

Can you send a print of the action of the timer? It seems that is an error on a Webservice call.

Can you check it?

Rank: #150

Hi Luis,

we don't have webservice call's.

Before instelling the new platform version, there was no problem at all.

Now after installing 10.0.1104.0 all timers stop at +/- 2 minutes...


Best regards.

Rank: #1073

Hi Jeroen,

In my case, I re-installed the configuration tool. I did the following step at the production on premise server and the issue resolved. It may be some setting or configuration file are corrupted.

1. Go to \Program Files\Outsystems\Platform

2. Open Platform Server Configuration Tool and press the "Apply and Exit" button

3. Wait until it completes


Hope that helps

mvp_badge
MVP
Rank: #65

HI Jeroen,

I hope you restarted the server after the security patch updates , i came into such situation after server updates  few times (not exactly same with the timer but others like service stopped ) and restarting server helped me out.

Also i would suggest you to rather doing something on configuration tool (Apply and Exit ) , please contact Outsystems Support as this is your production environment and you should not take any risk .

You can also try to restart the scheduler service and check if start working.


Regards,

-PJ-

Rank: #150
Solution

Issue solved by editing the recycling settings. In our case the Virtual memory was checked instead of the Private memory.


Best regards,


Jeroen

mvp_badge
MVP
Rank: #65

Hi Jereon,

Glad to hear that your issue has been solved and thanks for sharing the solution!

Regards,

-PJ-