Community Edition 5.1.19 broken on clean install - FIX/WORKAROUND

Community Edition 5.1.19 broken on clean install - FIX/WORKAROUND

So today I went to do a clean install of on a fairly clean Win 7 machine. It failed, and the message made little sense, something about named pipes not connecting and an error code 40. I tried a number of times, but it just didn't work. However, I found the root cause and a solution until OutSystems gets the installer fixed.

The underlying problem is that with a fresh install, the system is not configured for the local database. Throughout most of the installation, it uses the default SQL Express instance (localhost\SQLEXPRESS) just fine. But when it is performing the initial database deployment at the end of the Platform Server install, something goes wrong... the installation gets configured to use "localhost" as the DB server, and the configuration after that point fails.

After the installation fails, you will need to manually configure the database and retry the installation:

1. Start SQL Server Management Studio. Go to the Security\Logins and create a new user as a SQL Server user (NOT a Windows user!). Assign that user the "sysadmin" role.
2. Open the OutSystems Configuration Tool from the Start menu. On the first tab, change the "Server" field to "(local)\SQLEXPRESS". Then click the "Grant Permissions" button next to each user configuration box. When prompted for a username/password, use the username/password created in Step 1 (this tool doesn't like Windows usernames). Then click the "Create/Upgrade Database" button at the bottom. Go to the "Session" tab and click "Configure Session Database"; you will be prompted for the username/password and provide it the username/password from Step 1.
3. Click "OK" at the bottom to close out the Configuration Tool.
4. Re-preform the installation.

The only problem with this method is that the second install will set the DB to "outsystems_" instead of "outsystems", even if you delete the "outsystems" database after you create it in Step 2. I don't know how to get around this one.

I'm sure that OutSystems will fix the installer ASAP, but until then, this will do the trick.


Hi Justin,

Im trying to gather information to be able to replicate this problem.

Did you have already an instance of SQL on the server?
Can you submit an issue about this problem and include the file "C:\Program Files\Outsystems\Installer\"

João Rosado
Joao -

I submitted a ticket in the middle of trying to figure out how to solve it, I believe that Renato is working the case (156819). I am fairly sure that SQL Server Express was already installed, since the computer had a few other development tools on it, but it was most definitely a basic, un-configured installation, there were no other databases configured in it and the settings all looked default when I took a look at it. I know it wasn't a named pipes problem (even though that's what the error message said) because I tried enabling that and it didn't help. The problem is that after the platform server install and during the configuration, it sets the DB server to "localhost" (as seen in the Configuration Tool), which won't work, it needs to be set to "(local)\SQLEXPRESS" (or ".\SQLEXPRESS" or "localhost\SQLEXPRESS", etc.). As a result, when it tries to create the DB, it fails because "localhost" is not a valid reference to the SQL Express install.