[JWT Token] JWT Token - where to set iss, sub, exp (RFC Claim Names)

Forge Component
(0)
Published on 28 Jul by Karnan M
0 votes
Published on 28 Jul by Karnan M

Hi, I'm new to using extensions in Outsystems, and I'm also new to using JWT.
So my question may be very basic.

The RFC 7519 has these claims specified:

 4.  JWT Claims  . . . . . . . . . . . . . . . . . . . . . . . . .   8
     4.1.  Registered Claim Names  . . . . . . . . . . . . . . . . .   9
       4.1.1.  "iss" (Issuer) Claim  . . . . . . . . . . . . . . . .   9
       4.1.2.  "sub" (Subject) Claim . . . . . . . . . . . . . . . .   9
       4.1.3.  "aud" (Audience) Claim  . . . . . . . . . . . . . . .   9
       4.1.4.  "exp" (Expiration Time) Claim . . . . . . . . . . . .   9
       4.1.5.  "nbf" (Not Before) Claim  . . . . . . . . . . . . . .  10
       4.1.6.  "iat" (Issued At) Claim . . . . . . . . . . . . . . .  10
       4.1.7.  "jti" (JWT ID) Claim  . . . . . . . . . . . . . . . .  10

Where can I specify these claims, when I'm using this extension? I believe I need to somehow specify this in the JWTServiceGenerateToken action, but I'm puzzled by how I would do this.

Thanks

Solution

Hey Andras,

I've taken a look at the actions provided in the component you're looking at and also couldn't find a proper way to set those claims.

I believe that this component has a way to set those claims (and any other claim passed in the Claims input parameter):


Let me know if you need help setting up your token.

Cheers,

David

Solution

Thanks David,

I am developing a reactive web application. Can this "traditional web application" component be used somehow? How do I approach it in that case?

Andras,

In a reactive web application you can have server side code, where you should reference and use the relevant JWT server actions.

Try it out and let me know if it worked.


Cheers

David Sousa wrote:

Andras,

In a reactive web application you can have server side code, where you should reference and use the relevant JWT server actions.

Try it out and let me know if it worked.


Cheers

 Thanks David, This was exactly correct! Problem solved.