calling a service action gives error "HTTPS connection required".

After setting in Lifetime the environment security setting "Force HTTPS for exposed integrations in Web Applications" on TRUE, all the service action calls give now error:   "HTTPS connection required".

So those are Service Actions, not REST services.

How to deal with that ?

PlatformServer-11.9.1 (Build 20359)
DevelopmentEnvironment-11.8.8 (Build 30156)

Thank you !
Mihai Cotar
 

Hi Mihai,

I can imagine the Force HTTPS for exposed integrations setting applies to exposed Service Actions too since they are basically REST-based remote calls.

That said, I do think the documentation should mention Service Actions too if the setting applies to them.

I will follow this up with OutSystems.

Regards,

Nordin

Hi Nordin !

Apart from the documentation, the real issue is that I see no way I can call a service action with HTTPS. So there is no way to avoid the error. 
But perhaps I am missing something.
 

Regards, 

   Mihai  

Hi Mihai,

Let me ask you a couple of additional questions.

Are other requests (screens/REST API etc.) working properly with HTTPS enabled?

What happens if you disable the Force HTTPS for exposed integrations setting in LifeTime? Are you then able to call Service Actions?

Regards,

Nordin


>>Are other requests (screens/REST API etc.) working properly with HTTPS enabled?
- screens: Yes
- REST services: most of them did work as were called with HTTPS already, others called with HTTP worked only after changing the rest call to HTTPS
 

>> What happens if you disable the Force HTTPS for exposed integrations setting in LifeTime? Are you then able to call Service Actions?   

- Yes


Regards,

   Mihai

Hi Mihai,

OutSystems has analyzed this further and came to the conclusion that this is a bug in the platform:

  • Service action calls do not depend on the force HTTPS for exposed integrations at all for the calls. They are internal calls, and internal calls are http by default.
  • The calls run in https if the zone of the target module is configured to force https on internal communications.
  • It is a bug that having the first turned on with the second off makes all service action calls fail. Service Actions are supposed to always accept http requests regardless of any configurations.

Thank you for reporting this! Keep an eye on future Platform Server releases that will include a bug fix for this.

Regards,

Nordin