11
Views
10
Comments
Solved
Facing issue in domain pointing
Question

Hi,

For my traditional web application I have uploaded the SSL certificate on production, but domain is not working.

SSL certificate is wild card certificate : *.adani-irm.com

According to given article on this https://success.outsystems.com/Support/Enterprise_Customers/Installation/Use_your_SSL_domain_in_OutSystems_Cloud, we created CNAME records in DNS.

In our case CNAME record is  www.adani-irm.com -> apasl.outsystemsenterprise.com 

After uploading SSL certificate in LifeTime, url has been changed to www.adani-irm.com , But am not able to open ServiceCenter using this URL https://www.adani-irm.com/ServiceCenter.  When I tried to open service center using url apasl.outsystemsenterprise.com/ServiceCenter , I am able to open it but its showing as non secure page. 

Am not sure what is the reason of this. As I followed exactly given on above url and did same for another client.  Please suggest.




Regards

Rank: #95
Solution

Hi Vikas,


Indeed you should have forwarding for both www and without www. By the way, you can check the domains the certificate sign, with and without www, following these steps:

 1. Navigate to a page of your domain

 2. Click on the lock on the address bar before the URL

 3. Select option "Certificate (valid)"

 4. Select tab "Details"

 5. Select field "Subject Alternative Name"


Hope it helps.


Cheers,

João

Rank: #95

Hi Vikas,


You need to have the requests to your new domain  to be forwarded to apasl.outsystemsenterprise.com (CNAME). 

In my situation, I asked the infrastructure administrator who provided the certificate to arrange this and it works.

Even when arranged it can take a couple of hours before the redirect takes place.


Hope it helps.


Cheers,

João


Rank: #421

Hi Joao,

Thanks for update. But as per your suggestion "You need to have the requests to your new domain  to be forwarded to apasl.outsystemsenterprise.com (CNAME).  " , Do I need to do this in my domain hosting or in OutSystems infrastructure. If its in domain hosting then are you asking that there should be a Record in CNAME that should forward to apasl.outsystemsenterprise.com. Please suggest.


Regards

mvp_badge
MVP
Rank: #71

Hi Vikas,

Did you notice that requests to https://adani-irm.com/servicecenter/ (without www.) do work?

Maybe something your network administrator* can look into.

EDIT: *I meant network admin so I corrected it.

Regards,

Nordin

Rank: #95

It's not in outsystems platform. It was the network manager / certificate issuers that added the CNAME record to forward the requests.


By the way you should be able to test if the forwarding is in place, by pinging the new domaim in command line and see where it forwards to.


Cheers,

João

Rank: #421

Hi Nordin and Joao,

Thanks for update.

@Nordin : Yes you are right without www, am able to open service center and other applications as well. Seems Network admin pointed adani-irm.com -> apasl.outsystemsenterprise.com. Instead he should do something like : www.adani-irm.com -> apasl.outsystemsenterprise.com . Please suggest me if I am wrong.

Regards.

 


Rank: #95
Solution

Hi Vikas,


Indeed you should have forwarding for both www and without www. By the way, you can check the domains the certificate sign, with and without www, following these steps:

 1. Navigate to a page of your domain

 2. Click on the lock on the address bar before the URL

 3. Select option "Certificate (valid)"

 4. Select tab "Details"

 5. Select field "Subject Alternative Name"


Hope it helps.


Cheers,

João

Rank: #421

Hi Joao,

I checked the way as you suggest. But seems there is no forwarding with www. So in this situation is should be something like www.adani-irm.com -> apasl.outsystemsenterprise.com, instead of current adani-irm.com -> apasl.outsystemsenterprise.com.

Regards

Rank: #95

Hi Vikas,


The certificate is signing the *.adani-irm.com which means the www is included I think since the * is the wildcard. So from a certificate standpoint it seems correct.

Regarding forwarding, you need to check with your network manager but you can try by command line run ping adani-irm.com and ping www.adani-irm.com and the first one should be redirecting to Outsystems server ip and the other one failing.

You can use this to show your network administrator that the domain with www needs to also forward and the CNAME is missing.


Cheers,

João

Rank: #421

Hi Joao,

Thanks for update. Yes you are right. Ping with www is not working. So CNAME record should be create with www as well.

Regards.

Rank: #421

@Nordin & @Joao : Thank you both for making this clear to me.