21
Views
7
Comments
Solved
An error has occoured while fetching the requesting MABS version
Question

Hi Team,


We are facing below problem today on PROD environment.


We tried to deploy Mobile application from QA to PROD and we faced an issue during deployment, In service center we see the following errors under system modules

1.InvalidRequest: An error has occurred while fetching the requested MABS version.

2.Failed to request mobile generation for app (iOS) - InvalidRequest: An error has occurred while fetching the requested MABS version.


Steps we tried to resolve:

1. Re-generate the IPA

2. Redeploying application from QA to PROD

Any help appreciated.



MABSError.JPG

Rank: #43
Solution


Fix was performed by OS directly on MABS. so no need to do any change from user end.

User just need to trigger new build

Rank: #2088

Hi,


you need to check your app MABS version in both environments.see in the below screenshot.


If both are not the same please change by clicking Configure links see in bottom there is option to change MABS version.

Also, check this link
https://success.outsystems.com/Documentation/11/Delivering_Mobile_Apps/Mobile_Apps_Build_Service


Thanks!!


Rank: #170

Same problem here!
Started some days ago...
Seems like MABS service is not working properly...

Any solution?

Rank: #170

Just checked my integrations error tab in service studio and validated that the MABS service is always returning erros.

I enabled the full logs for this service and saw that the error being returned is:


{

  "Success": false,

  "Error": {

    "Code": "ERR-RQB-1001",

    "Message": "InvalidRequest: An error has occurred while fetching the requested MABS version."

  }

}


someone have any information about OutSystems support, if the service is with any problem?

Rank: #170

Hey guys,

Seems like older versions of Platform Server was having this issue.

Opened a support ticket and found out that the max version of MABS, for Platform Server older than version 10.0.1005.2, was 5.

Since all 5.x versions had been deprecated, the MABS service were generating an error.

Here is the answer given by support:



I also asked what version will be used for now on, for older platform versions, and let you know...

Cheers and Regards,

RR :)

Rank: #170

Hey guys,

The problem generating the apps using MABS seems to be solved.

The version of MABS used at least at PS (Platform Server) 10.0.804.0 for now is 5.2:


As I have another problem where I need to use a newer version of MABS still using an older version of PS, I'm still checking if there is a way to do it.

I will post any news about this other matter in this topic, since the problem is not directly related to the one being asked here.

If anyone in future needs to use a newer version of MABS in Older PS than 10.0.1005.2 (Where was given the option to choose the version of MABS)... check the other link.


Cheers and Regards,

RR :)

Rank: #43
Solution


Fix was performed by OS directly on MABS. so no need to do any change from user end.

User just need to trigger new build