8
Views
2
Comments
504 Gateway Time-out nginx/1.15.7
Question

Hi All,

I am connecting from outsytem to external API using REST API URL,if there is a two records from external response, Got a success Response

When Response is more than 100 records it takes quite time to execute meanwhile got a error message as given below but all records are processed successfully in external API.

FYI:API connected to WSO2

HTTP/1.1 504 Gateway Time-out

Connection: keep-alive

Content-Length: 167

Content-Type: text/html

Date: Wed, 21 Oct 2020 11:56:41 GMT

Server: nginx/1.15.7


<html>

<head><title>504 Gateway Time-out</title></head>

<body>

<center><h1>504 Gateway Time-out</h1></center>

<hr><center>nginx/1.15.7</center>

</body>


</html>


Please let me know if there is a way to fix the issue.


Regards,

Ganesh kumar.C

Hi Ganesh,

From the error stack it seems the problem is on the other end of the connection. By default nginx timeout is 60 seconds. By default the timeout for REST APIs in OutSystems is 100 seconds. You can check it in Service Studio:



If you cannot increase the connection timeout on the other end you might have to refactor your code. One option is to breakdown your payload in smaller chunks instead sending it at once.