5
Views
1
Comments
Could not load file or assembly 'Microsoft.Office.Interop.Word, Version=15.0.0.0
Application Type
Traditional Web
Service Studio Version
10.0.1024.0
Platform Version
10.0.1023.0

Hi,


We have some C# extension (i don't really know where it came from) to convert docx files to pdf. But I recently started to give an error (Could not load file or assembly 'Microsoft.Office.Interop.Word, Version=15.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c' or one of its dependencies. The system cannot find the file specified).

We just migrated to Outsystems platform version 10 and we believe it might be related to that.

After some research, the following has already been done:

  • Install on server office 2016 (on server we have office 2010 and 2016 on client machines), but the error continues;
  • Embed some interop files, but the result was de same;
  • Change the interop files to 12 version (nuget package manager);

There are other extensions in forge, but some uses wesite to convert de word (and we do not want to send files) and others are only for v11.

Any idies, please.

mvp_badge
MVP
Rank: #51

Hi Hugo,

Please have a look on this link , someone in stack overflow has the same problem and after few suggestions he marked his problem as solved .


Regards,

-PJ-