22
Views
6
Comments
Service Studio doesn't open a dedicated Chrome browser instance for debugging PWA
Question

After server upgrade and switching on PWA I created mobile application and try to debug it. However debugger is not possible and some other wired this happen:

  • Service Studio should open a dedicated Chrome browser instance for debugging only but it doesn't open it! So debugging is not possible.
  • WEB application debug session can be run but breakpoint is not work and if I set one more breakpoint I get message that debug session was closed
  • PWA switcher in Service Studio causes connection error while Service Center allows to do it
  • Default page is not found error in preview device view if URL doesn't have page name while default page is set
  • Navigation by application link in the browser causes not found error because page name contains .aspx postfix

Ticket for OS support is created but has somebody faced with such issue and find a way to fix it?

Platform version is 11.9.1

Rank: #5701

Hi Valerij.


I have the same problem here. Do you have On premises environment??

After upgrade, did you publish all applications on a Solution?

Waiting for you answer to try help 

Felipe, we have on premises env. Everything what could be update was updated and published. We have ticket to OS in progress. It looks like there is some configuration issue starting from 11.8.0. version.

Here is some  fragment from OS answer which could help you to fix issue or create ticket to OS with proper details:

Upon further analysis, we suspect that this issue may be related to a change of behavior in the debugger that started on version 11.8.0. For this we would like to suggest the following:

  • Could you please add the Load Balancer IPs to the Trusted Proxy Addresses and retry? This should be added in: Service Center>Administration>Security>Network Security.
  • Confirm if the tests to the endpoints https://environment_name/server.api/v1/health where made from the same machine where the SS is running
  • Could you please evaluate what are the target IPs (see attachment[1]) that appear to throw the 403?
  • At this point, if the issue persists, please unblock (temporarily ) the access to /server.api/ and /server.identity/ in the firewall and test the behavior.
  • Do you have a Default Proxy Enabled in the IIS? If so, what's it's configuration?

Adding end user IP to Trusted Proxy helped. But it is temporary solution. Waiting for OS help.

Rank: #5701

Valerij, we don't have default proxy enabled.

To solve this question in Development Environment, I use only one front-end server, no load balancer.


Felipe, I think you should create a ticket since we have different configuration and our temporary solution is not applicable for you.

Rank: #5701

Yes, Valerij.


I will create a ticket.

Thanks.