24
Views
12
Comments
Solved
Service Studio IDE doesn´t render well
Service Studio Version
11.10.4 (Build 36716)

Hello,

I installed IDE 11.10.4, but I noticed a rendering problem.

The IDE doesn't show anything until I resize it.

This happens every time I try to do something within an application too, so it is impossible to work.

video here

Rank: #740
Solution

Problem found and solution. 

It's related to 11th gen Intel processors with Iris Xe, Hardware Acceleration. 

With this feature ON I can´t work with Service Studio. 

Solution: (at least for now)

Hardware acceleration needs to be disabled if you have an 11th generation Intel chip with Iris Xe graphics and are experiencing the described problems.

The command disables hardware acceleration for WPF applications only, not your whole system.

  1. Service Studio Off
  2. Press  +R
  3. type cmd
  4. Click Ok 
  5. Click Command Prompt
  6. Copy and paste the following into the Command Prompt and press the Enter/Return key
  7. reg add HKCU\SOFTWARE\Microsoft\Avalon.Graphics /v DisableHWAcceleration /t REG_DWORD /d 1
mvp_badge
MVP
Rank: #17

Great that you where able to find the issue and that you shared the workaround here.

Rank: #1382

Great!
I was also disappointed whit this issue.
Thank you very much for the workaround. Works like a charm.

Now, it really seems like an Intel or Windows driver issue.
I found this link reporting the same issue and proposing the same workaround:
https://support.logos.com/hc/en-us/articles/360052821231-Display-problems-on-11th-gen-Intel-processors-with-Iris-Xe

mvp_badge
MVP
Rank: #17

Hi Ivan,

The link to the .mp4 is actually a link to your OutSystems support case. Non of the community members will have permission to see that (for good reasons).

I have the same version of SS installed and using it the last days without any problem

Does the problem go away if you deinstall  version 11.10.4, install 11.10.0 and keep auto-update off?

Regards,

Daniel

Rank: #740

Hi Daniel,

I already changed the video link.

Yes, I tried other versions, and the problem persists.

Regards

mvp_badge
MVP
Rank: #131

I try to open the link but it redirects to a vídeo hosted on Google drive that Is not public. Can you try to change the permission access level to public?

Rank: #740
mvp_badge
MVP
Rank: #17

Seems to be a problem on your PC, not specifically to any SS version. Did you check CPU usage?

Rank: #740

Everything is fine with CPU. It is probably more related to the screen resolution, but I have already switched to all possibilities.

The PC is the new Asus Zenbook 14.

Rank: #740

Hi guys,

New video file here.

Thks

Rank: #2609

Hi Ivan,

Have you tried to change the size of the text (Scale and layout) on the display settings?

Best Regards,
Bruno Ferreira

Rank: #740

Hi Bruno,

Yes, I tried all, and nothing, the problem persists.

Best Regards


Rank: #740
Solution

Problem found and solution. 

It's related to 11th gen Intel processors with Iris Xe, Hardware Acceleration. 

With this feature ON I can´t work with Service Studio. 

Solution: (at least for now)

Hardware acceleration needs to be disabled if you have an 11th generation Intel chip with Iris Xe graphics and are experiencing the described problems.

The command disables hardware acceleration for WPF applications only, not your whole system.

  1. Service Studio Off
  2. Press  +R
  3. type cmd
  4. Click Ok 
  5. Click Command Prompt
  6. Copy and paste the following into the Command Prompt and press the Enter/Return key
  7. reg add HKCU\SOFTWARE\Microsoft\Avalon.Graphics /v DisableHWAcceleration /t REG_DWORD /d 1
mvp_badge
MVP
Rank: #17

Great that you where able to find the issue and that you shared the workaround here.

Rank: #1382

Great!
I was also disappointed whit this issue.
Thank you very much for the workaround. Works like a charm.

Now, it really seems like an Intel or Windows driver issue.
I found this link reporting the same issue and proposing the same workaround:
https://support.logos.com/hc/en-us/articles/360052821231-Display-problems-on-11th-gen-Intel-processors-with-Iris-Xe