6
Views
4
Comments
Solved
Container with: max-height: 660px;  overflow: auto;
Question
Application Type
Reactive

I'm hoping there is a quick and simple answer to this.

I have setup a container with a max-height so that users get a vertical scroll bar when using the app.

Unfortunately the max-height is applying in the Development studio as well, and I can only see a handful of the fields that make up my display.

I need a way to override the max-height setting for the Development studio only..

I'm pretty sure this is a rookie question with a simple answer..

Rank: #2250
Solution

Unfortunately Service Studio honors the styles that you apply to the forms just like the browser.  I think this is likely so that you get a better idea of what the application will look like when you actually deploy it. 


Fortunately there is a way around it:



If you set the style such that you have an If (False), Service Studio will honor the first branch of the statement, even though the browser will honor the second.


Hope this helps!

Rank: #1301

That works a treat!  Many thanks..

Rank: #450

Hi Steve

Afaik you can't change max-height for design-time only.

You can disable overflow at design-time, then before you publish the app change back the CSS.

Maybe someone has a better solution.

Kindly Regards

Rank: #1301

Thank you.

Hopefully somebody has a better solution..

Rank: #2250
Solution

Unfortunately Service Studio honors the styles that you apply to the forms just like the browser.  I think this is likely so that you get a better idea of what the application will look like when you actually deploy it. 


Fortunately there is a way around it:



If you set the style such that you have an If (False), Service Studio will honor the first branch of the statement, even though the browser will honor the second.


Hope this helps!

Rank: #1301

That works a treat!  Many thanks..