10
Views
1
Comments
[Background Geolocation Services] How can i generate ios app include this plugin using MABS version 6.3?
Question
Forge component by Kevin Neeter
1
Published on 06 Feb 2019
Application Type
Mobile

Hi,

When generating ios app, it said " Error generating application. At least one Cordova plugin used in the build requires Swift but no "Swift Language Version" build setting was defined. Check your plugins configuration. "

 The MABS Version is 6.3, and seems it is using swift 5, but the background-geolocation-services is using swift 3 so this error occur?

When using MABS version 5.2 and set UseSwiftLanguageVersion to 3 in configuration it successfully generates the ios app, but since 5.2 is deprecated, we still prefer to use the latest MABS version.

Is there any way to solve this? Thanks!