12
Views
8
Comments
Internal compilation error CS0009 when publishing an application
Application Type
Reactive
Service Studio Version
11.10.6 (Build 37198)

Hi,

I've tried to publish a change of the application Gestion_Cuestionarios in Service Studio and I've got the below error:

Internal Error

Compilation Error.
fatal error CS0009: Metadata file 'c:\OutSystems\Sandboxes\JRRA4I042\Platform Server\share\Gestion_Cuestionarios\full\bin\OutSystemsCharts.dll' could not be opened -- 'The system cannot find the file specified.'

It was working the last time some weeks ago and I was able to access to the application in the browser. I don't know why it's not working now and how to solve this error.

Could you please help me on this?

Thanks & Regards,

GestionCuestionariosv133.oml

Rank: #510

Hi Monica, 

I opened your oml file and it works fine to me. What happens when you try to manage dependencies of the module?

Regards

Rank: #287

Hi Monica

I also tried your Oml, It works for me too. I just remove some not defined action.

The error message look's like you lost some dll file, You can try something below

1, The chart dll is missing, But in your oml file you don't need chart, So you can remove unused dependencies.

2, ReInstall or Update your service studio.

Kind Regard


Hi Kadu and Tom,

Many thanks for your quick feedback. You're right, it seems something is wrong with my dependences. I am able to apply some new dependences, however when publishing the application I get compilation errors (the ddl files are not found).

I've removed the OutSystemsCharts dependence as suggested, however I've got another error because the Users.ddl is not found and this is required.

Do you know how I can get these dependences working without reinstalling again Service Studio?

Thanks & Regards,

Hi,

I'm still facing the same issue, I'm not able to manage successfully the dependences. 

I've also tried to create a new application from scratch, however I've faced another problem: Too many automatic redirections were attempted. PFA the screenshot of the error.

I'm quite worried because my environment is not working properly since two days ago and I'm stuck.

Could you please help me on these problems?

Many thanks in advance.

Createapplicationerror.docx

Rank: #510

Hi Monica,

I saw something today that might help you with this issue, if it is still occurring.

Use service studio by command line with -recover option. 


"Service Studio can be found in C:\Program Files\OutSystems\Development Environment 11\Service Studio, the executable is called ServiceStudio.exe. Type "servicestudio -recover yourmodule.OML" to fix any errors."

Regards

Hi Kadu,

Many thanks for your feedback. I've just tried your suggestion however I'm still facing the same error with the dependences and I'm not able to create an application from scratch as per my last comment.

I don't know why service studio is not working properly since some days ago. I think I should reinstall it again and see how it is working.

I'll let you know.

Thanks & Regards,

Hi Kadu,

I have good news, I've reinstalled the Servide Studio 11.10.8 and I was facing the same errors with the dependences in the Service Studio. However I've checked the modules in Service Center and realized that many of them were not up to date and I've published them again.

Once all the modules were up to date I published and opened my application from the Service Center and it worked. After that I tried to apply some changes and publish my application from the Service Studio and it worked. Therefore I could say that the issue regarding the dependences is solved.

The only problem that I'm still facing is when creating a new application from scratch. The error message is: Too many automatic redirections were attempted.

Do you know how I could solve this problem?

Many thanks & regards,

Rank: #510

Hi Monica,

Good news, indeed. Well, I never saw that error and I have done some research about it e found nothing about it. Just problems with bad flows in server or screen actions.

Best regards.