6
Views
1
Comments
[Sankey Diagram] Error when navigating away from a screen with a Sankey Diagram block.
Forge component by Daniel Martins
0
Published on 22 Mar 2020
Application Type
Reactive

Hi, 

When we navigate away from a page that has a Sankey Diagram block on it, we get an error:

Mismatched anonymous define() module: function(exports, d3Array, d3Collection, d3Shape) {

'use strict';


function targetDepth(d) {

....

<tons of javascript that I've trimmed.  It appears to be the contents of the d3_sankey script>

....

Object.defineProperty(exports, '__esModule', { value: true });

  }

http://requirejs.org/docs/errors.html#mismatch

    at makeError (https://<our tenant>.outsystemscloud.com/SankeyDiagramSample/scripts/OutSystems.js?5nDbdRKHkFGAjYmzYfZYrQ:1:1016)

    at y (https://<our tenant>.outsystemscloud.com/SankeyDiagramSample/scripts/OutSystems.js?5nDbdRKHkFGAjYmzYfZYrQ:1:4633)

    at Object.o [as require] (https://<our tenant>.outsystemscloud.com/SankeyDiagramSample/scripts/OutSystems.js?5nDbdRKHkFGAjYmzYfZYrQ:1:11095)

    at requirejs (https://<our tenant>.outsystemscloud.com/SankeyDiagramSample/scripts/OutSystems.js?5nDbdRKHkFGAjYmzYfZYrQ:1:14728)

    at Object.c [as onEnter] (https://<our tenant>.outsystemscloud.com/SankeyDiagramSample/scripts/OutSystemsReactView.js?i6se5IhdNMnGAKCelYhsFQ:9:13586)

    at Array.<anonymous> (https://<our tenant>.outsystemscloud.com/SankeyDiagramSample/scripts/OutSystemsReactView.js?i6se5IhdNMnGAKCelYhsFQ:8:28455)

    at https://<our tenant>.outsystemscloud.com/SankeyDiagramSample/scripts/OutSystemsReactView.js?i6se5IhdNMnGAKCelYhsFQ:8:28958

    at https://<our tenant>.outsystemscloud.com/SankeyDiagramSample/scripts/OutSystemsReactView.js?i6se5IhdNMnGAKCelYhsFQ:8:28851

    at i (https://<our tenant>.outsystemscloud.com/SankeyDiagramSample/scripts/OutSystemsReactView.js?i6se5IhdNMnGAKCelYhsFQ:8:4224)


    at Object.n [as loopAsync] (https://<our tenant>.outsystemscloud.com/SankeyDiagramSample/scripts/OutSystemsReactView.js?i6se5IhdNMnGAKCelYhsFQ:8:4337)

Staff
Rank: #66

Hi Greg,

Thank you for letting me know about this issue. I ever noticed it, this was just a sample plugin, I never used in any project and sample has only one page.

I was able to replicate the issue, I will have a look and try to understand what is causing this issue.

Hope giving you more feedback about this issue soon.