9
Views
2
Comments
Solved
cache validation service installation Error (On Prem)
Question
Platform Version
11.10.2 (Build 25738)

I am trying to install platform server on Prem. I have installed platform binary with pre-requisite for RabbitMQ and erlang installed automatically. Facing below error while configuring CACHE tab in configuration Toll 11. Below error comes while Create/Upgrade service button click.


Cannot convert value "

******************************

ERLANG_HOME not set correctly.

******************************

Please either set ERLANG_HOME to point to your Erlang installation or place the

RabbitMQ server distribution in the Erlang lib folder.

" to type "System.Version". Error: "Input string was not in a correct format."

At C:\Program Files\OutSystems\Platform Server\scripts\RabbitMQ\RabbitMQ_Installation.ps1:356 char:16

+         return [version]$Version

+                ~~~~~~~~~~~~~~~~~

    + CategoryInfo          : InvalidArgument: (:) [], RuntimeException

    + FullyQualifiedErrorId : InvalidCastParseTargetInvocation

 

RabbitMQ is installed but could not find its version. Aborting.

At C:\Program Files\OutSystems\Platform Server\scripts\RabbitMQ\RabbitMQ_Installation.ps1:372 char:5

+     throw "RabbitMQ is installed but could not find its version. Abor ...

+     ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    + CategoryInfo          : OperationStopped: (RabbitMQ is ins...sion. Aborting.:String) [], RuntimeException


    + FullyQualifiedErrorId : RabbitMQ is installed but could not find its version. Aborting.


Steps I have followed

  1. Checked ERLANG_HOME Environment variable in system and value is C:\Program Files\OutSystems\Platform Server\thirdparty\Erlang\bin\erl.exe
  2. rabbitmqctl.bat status  showing  ERLANG_HOME not set correctly.

Any lead in this regards?

Rank: #34807
Solution

Thanks for your quick response. 

I have gone through all point you said but it didn't work for me.  After many attempts issue got fixed and issue was i have set simple password in cache admin credential and it works. Before i was using complex password.


Rank: #312

From: https://www.rabbitmq.com/install-windows-manual.html#install-erlang

RabbitMQ requires a 64-bit supported version of Erlang for Windows to be installed. Latest binary builds for Windows can be obtained from the Erlang/OTP Version Tree page.

Erlang will appear in the Start Menu, and \erl{version}\bin\erl.exe will be in C:\Program Files for 64-bit Erlang installations

Important: your system should only have one version of Erlang installed. Please consult the Windows-specific Issues page.

Make Sure ERLANG_HOME is Set

In case there's an existing RabbitMQ installation with the broker running as a service and you installed an Erlang VM with a different architecture then the service must be uninstalled before updating ERLANG_HOME.

Set ERLANG_HOME to where you actually put your Erlang installation, e.g. C:\Program Files\erl{version} (full path). The RabbitMQ batch files expect to execute %ERLANG_HOME%\bin\erl.exe.

Go to Start > Settings > Control Panel > System > Advanced > Environment Variables. Create the system environment variable ERLANG_HOME and set it to the full path of the directory which contains bin\erl.exe.



So i think you should make sure erlang is installed, the environment variable is set, and maybe re-install RabbitMQ.


Rank: #34807
Solution

Thanks for your quick response. 

I have gone through all point you said but it didn't work for me.  After many attempts issue got fixed and issue was i have set simple password in cache admin credential and it works. Before i was using complex password.