16
Views
10
Comments
Solved
Mobile App Generation Failed
Application Type
Mobile
Service Studio Version
11.10.10 (Build 38777)

Good Day,


Hi I am having a problem generating the mobile app as errors are found based on the logs. I was not able to copy all the error logs since it has link to the environment I am not sure if it is safe to post it here so I only included does with the word [Error]. It says something about the cordova plugin and would like to ask your inputs on how to troubleshoot this. Any help would greatly be appreciated.

Rank: #1335
Solution

Hi,

Your problem seems to be the same as this: https://www.outsystems.com/forums/discussion/68233/error-build-for-android/.

You are using the version 4.3.3 with MABS 6.3/7.0. Perhaps with the version 6.0.2 (latest) of the File Plugin, you can resolve the issue.

Kind regards, David.

Hello David thank you for your reply. 


Just to be clear am I doing it right?

I opened the lifetime navigated to the fileplugin clicked on settings, then proceeded to the image attached below. Changed the Default to Custom then added the following.




mvp_badge
MVP
Rank: #17

Hi Leonard,

I think you forgot to share the errors.

Regards,

Daniel

Hi Daniël, 

I attached the error logs below. 


ErrorLogs.txt

Rank: #681

Hi Leo,

  please share at least one line error what coredova plugin error return.





Hi CV Sharma, 


here is the error logs. Sorry did not know why it was not attached properly.

ErrorLogs.txt

Rank: #86

Hi there Leonard,

Hope you're doing well.


Is this situation occurring after the addition of a new plugin?


Looking to your logs, it seems that the problem is related with https://github.com/apache/cordova-plugin-file.git#4.3.3, which corresponds to File Plugin.

Which MABS version are you using?

Is this error happening only for Android or it also happens for an iOS build?


Kind regards,

Rui Barradas

Hi Rui,

Thank you for reaching out. Here is my MABS Version 6.3

Is there anything I have to do?


However there is another concern upon viewing on Service Center its on 7.0? Does this have any effect on the generation of the app? Sorry I am unable to understand this totally

Rank: #1335
Solution

Hi,

Your problem seems to be the same as this: https://www.outsystems.com/forums/discussion/68233/error-build-for-android/.

You are using the version 4.3.3 with MABS 6.3/7.0. Perhaps with the version 6.0.2 (latest) of the File Plugin, you can resolve the issue.

Kind regards, David.

Hello David thank you for your reply. 


Just to be clear am I doing it right?

I opened the lifetime navigated to the fileplugin clicked on settings, then proceeded to the image attached below. Changed the Default to Custom then added the following.




Rank: #1335

Hi,

Perhaps it is better install the version 3.0.1 from File Plugin.

This version uses what you need.

Kind regards, David.