[InAppBrowser Plugin] Unable to generate iOS mobile app due to InAppBrowser error
Question
Forge component by OutSystems R&D
Application Type
Mobile

There's an error encounter during generation of iOS mobile app. Please see the attached file for the error log encountered during generation. Thank you in advance.

Hi having the same issue , MABS version is 7.0


[2021-03-11T02:18:34.386Z] [ERROR] [Build] ** ARCHIVE FAILED **

[2021-03-11T02:18:34.386Z] [ERROR] [Build] The following build commands failed:

[2021-03-11T02:18:34.386Z] [ERROR] [Build] CompileSwift normal arm64 /var/lib/builder03/builds/40f666b4-6feb-40bf-9d11-ab2c9db78c34/source/platforms/ios/GCF\ MobiApp\ Mobile\ app/Plugins/cordova-plugin-inappbrowser/SafariBrowserPlugin.swift

[2021-03-11T02:18:34.386Z] [ERROR] [Build] CompileSwiftSources normal arm64 com.apple.xcode.tools.swift.compiler

[2021-03-11T02:18:34.386Z] [ERROR] [Build] (2 failures)

[2021-03-11T02:18:34.386Z] [ERROR] [Build] xcodebuild: Command failed with exit code 65

[2021-03-11T02:18:34.387Z] [ERROR] [Build] Build failed with the following error: An unexpected error has occurred while generating your application. Please try again. If the problem persists, contact OutSystems Support.


Hi,
Make sure you're using a stable & latest version Version 2.4.1of InAppBrowser.
Coz I am able to build the apk for both platforms smoothly at my end.


thanks,
Assif

so plugin is
{"plugin":{"url":"https://github.com/OutSystems/cordova-plugin-inappbrowser#4.0.0-OS3"}}

and looks like i got the latest version as well.

I'm using the same version as well. 

Hi 

    please check outsystemsUI is updated or not.  try to update the plugin it will automatically.give a try


Thanks.

Hi,

In my experience, I've another plugin that use Swift Support Plugin and it seem has conflict with In App Browser.

I think it is because the default of "UseSwiftLanguageVersion" set at Swift Support Plugin does not match with In App Browser. In my case, I've t set it to 5 at my App's Extensibility Configurations.

"ios": [

            {

                "name": "UseSwiftLanguageVersion",

                "value": "5"

            }


        ],

Hi,

I think it is the same problem than in this thread https://www.outsystems.com/forums/discussion/68634/in-app-browser-getting-cant-find-variable-cordova/.

The solution was removed completely the plugin SwiftSupportPlugin. It is not necessary with MABS 6.3/7.0.

Kind regards, David.

Hi @David Vaello

I already removed the SwiftSupportPlugin in my application dependency but I still can't generate the app.

Hi,

Can you share the full log? I think that the problem is the incompatibility between plugins. If you create a new test mobile app with only this plugin, can you generate the IOS app with MABS 7.0?

Kind regards, David.

Hi @David Vaello  please see the attached file. This is generated with mabs 7.0

iOSBuildLog6.txt

Hi,

You must review the plugins you need in your app and their versions. If you don't need it, you must remove the dependency in order to avoid incompatibilities in the compilation process. 

In the other hand, you can try to update to latest version of the plugin. The OutSystems module of the plugin wraps a Cordova plugin. The Cordova plugin can have other dependencies.

For example, you are using an OutSystems module that uses the cordova-plugin-fingerprint-aio#v3.0.1. This version depends to cordova-plugin-add-swift-support which is incompatible with cordova-plugin-inappbrowser.

So, I would start by removing unwanted dependencies and by updating versions in modules you need. Finally, what plugins and versions do you need in your app?

Kind regards, David.


Hi @David Vaello ,

I already updated the version to 2.0.2 and build it by MABS 6.3 but still encountering an error regarding xcode.

Here's the reference for building it by MABS 6.3 https://www.outsystems.com/forums/discussion/67468/cordova-plugin-add-swift-support-getting-issue-while-generating-ios/

 Please see the attached file. Thank you

iOSBuildLog17.txt

Hi,

I have added in my personal environment with MABS 7.0 these plugins:

You must follow 2 steps:

1. Update version of plugins
You must update the version of the plugins of your app. In your log I can see old versions.
My versions vs yours:

  • FileChooser: 1.1.0 (OK)
  • File: 3.0.1 (KO)
  • FileViewer: 1.0.5 (KO)
  • InAppBrowser: 2.4.1 (OK)
  • TouchId: 3.3.0 (KO)

You can update the plugins directly in Service Studio (tab Forge).


2. Update FileChooser Plugin
In Service Studio open the FileChooserPlugin module. Remove the SwiftSupportPlugin dependency.


Publish module and refresh dependencies in your mobile app. Now you shouldn't have any error in the compilation with MABS 7.0.

Kind regards, David.

Hi

not using the SwiftSupportPlugin and also updating the outsystems UI doesn't seem to work either .

Thanks

Hi,

I would suggest you to create a new test mobile application and to add only this plugin. With the dependency in the module is enough to generate the IOS mobile application in MABS 7.0. 

Can you get to generate the IOS app with MABS 7.0? If not, can you share the log file?

Kind regards, David.

Disregard my earlier statement, it was due to the use of 'cordova-plugin-add-swift-support' located in a another plugin called cordova-plugin-nativegeocoder which was using a older version of cordova-plugin-add-swift-support this was then built first and therefore the updated version of cordova-plugin-add-swift-support was ignored(attachment), removing that plugin solved the issue for me.

Thanks


log.txt

Ok. It does make sense. :-) I'm glad that it already works for you.

Hi Jan Patricia Espina

I had a similar problem, got it solved by changing the MABS version that generates the mobile app. I was using version 7.0 and changed it to 6.3, which solved the issue. 

I solved going into the Service Center -> Applications -> Your app -> Tab Distribute. Click in Configure (for the platform that you pretend, iOS or Android), and then you can change your MABS version.

After the change tries to generate again.

Check the screenshots.



Regards

Gonçalo Almeida

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.