IDP: The remote server returned an error: (405) Method Not Allowed.
Question
Application Type
Service
Service Studio Version
11.10.15 (Build 39829)
Platform Version
11.10.3 (Build 27323)

IDP and IDP Customizations are working great on our dev and QA servers, but, even though we've verified (we think) that everything is set up identically on our prod servers, we're getting an error when trying to log in with Azure AD. The prod servers are two servers that are load balanced, which should be the only difference in the environments. The stack trace is below; can anyone help? This is our first OutSystems application and we're stuck.

Thanks,

Linda

The remote server returned an error: (405) Method Not Allowed.
at ssIdP.RsseSpaceIdPCustomizations.IdPCustomizationsServiceAPIClients.Custom_User_Check(HeContext heContext, String inParamSamlAppName, STUserData_CustomLogicStructure inParamUserData, Nullable`1 inParamUseAutoUserProvision, Nullable`1 inParamOnboardingGroupId, Nullable`1 inParamMapName, Nullable`1 inParamMapEmail, Nullable`1 inParamMapMobilePhone, Nullable`1 inParamMapExternalId, RLClaim_CustomLogicList inParamClaim_CustomLogic, Int32& outParamUserID)
at ssIdP.RsseSpaceIdPCustomizations.Custom_User_Check(HeContext heContext, String inParamSamlAppName, IRecord inParamUserData, Nullable`1 inParamUseAutoUserProvision, Nullable`1 inParamOnboardingGroupId, Nullable`1 inParamMapName, Nullable`1 inParamMapEmail, Nullable`1 inParamMapMobilePhone, Nullable`1 inParamMapExternalId, RecordList inParamClaim_CustomLogic, Int32& outParamUserID)
at ssIdP.Actions.ActionUser_Check(HeContext heContext, Boolean inParamUseCustomConfig, STUserDataStructure inParamUserData, Boolean inParamUseAutoUserProvision, Int32 inParamOnboardingGroupId, Boolean inParamMapName, Boolean inParamMapEmail, Boolean inParamMapMobilePhone, Boolean inParamMapExternalId, String inParamAppConfigName, RLClaimList inParamClaims, Int32& outParamUserID)
   at ssIdP.Flows.FlowAuth.ScrnIdP.Preparation(HeContext heContext)

Solution

Thanks. In our case we had to turn on Use HTTPS for internal communications in our Global Deployment Zone. That solved the problem with IDP, as well as with our other apps.

Champion

In my case, i switched to use https in my API. I think http is currently blocked by many of the browser.


Hope it helps

Solution

Thanks. In our case we had to turn on Use HTTPS for internal communications in our Global Deployment Zone. That solved the problem with IDP, as well as with our other apps.

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.