How to stop Autofill for Input Field
Question
Application Type
Reactive
Service Studio Version
11.10.17 (Build 40957)
Platform Version
11.10.0.27532

Hi Team,

How can we stop Autofill for Input Field?


I assume that autocomplete and autofill is different.

Below snap is the autocomplete behavior and above snap is the autofill behavior.

To stop autocomplete below behavior I tried using either of the options autocomplete = "nope" or autocomplete = "off".

Regards,

Vinod

mvp_badge
MVP

Hi Vinod,

This seems the auto-complete of Google Chrome. I'm not sure if you can apply some CSS to prevent that from happening.

Hi Vinod.

I share Kilian's opinion. It seems like browser auto-complete.

Take a look at this post because it did work - https://www.outsystems.com/forums/discussion/40657/stop-form-from-remembering-previous-inputs/

I tried implementing it earlier. It fixed the second behavior and not the first behavior.

Are you always using that browser?

You can try and disable autofill.

Hi Vinod,

Please try as per following screen shot , add extended property to the input field that you want to stop the auto fill


Hope this Help you,

Regards,

Komal


Hi Vinod, 

This is the browser feature. But we can add an attribute named 'autocomplete' with the value 'off' to the input field to disable this feature. BTW, if the Input Field is for password, then we can set the value to 'new-password' to the attribute. 

Hope this help you, 

Regard.

I tried implementing it earlier. It fixed the second behavior and not the first behavior.

for the first behavior, maybe can try add this attribute to the Form that the Input Field belongs to.

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.