Is there a way where we can get HTTP2 to work on our reactive web app?
Question

Is there a way where we can get the HTTP2 protocol to work with our reactive web app?

Our website is immensely slow and the http2 protocol will help, but I have found out from a previous thread in the forum that it is not currently possible, so I wanted to check if this is true

Thank you.

mvp_badge
MVP

Hi Hossam,

It is currently not possible to use HTTP2 protocol with OutSystems Apps. 

Why do you think HTTP2 would solve the slowness of your website? Perhaps there is another reason what is causing the performance issue.

Regards,

Nordin

Hi Nordin,

It was suggested by one of Outsystems Customer Support agents as a possible solution to the issue, which to my surprise I discovered that the http2 protocol doesn't even work with Outsystems App. Can you imagine that? 

Another disappointment to be added to the (Doesn't work with Outsystems List).

mvp_badge
MVP

Hi Hossam,

That is really odd. Unless I'm not aware of HTTP2 protocol currently being supported, but last thing I heard it wasn't. 

Let me ask around and get back to you.

Regards,

Nordin

Thank you Nordin, I appreciate your kind help.

mvp_badge
MVP

Hi Hossam,

I found out a couple of things.

I was made aware that HTTP2 is currently being used in some places. I've checked out one of my Reactive Web Apps on my Personal Environment and as you can see, the requests being made do use HTTP2 protocol.

As I understood further, HTTP2 protocol was disabled for Enterprise Cloud environments because of huge performance impact on large upload requests.

For on-premises installations you should be able to use HTTP2 if you meet the requirements.

Hope this helps.

Regards,

Nordin

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.