[Azure AD Mobile Plugin] Error when generate apps
Question
Forge component by Pedro Costa

Hi,

When i added this plugin, it comes the errors following. is it something wrong on my configuration ?

IOS:

Error installing Cordova plugin: cordova-plugin-ms-adal. Using "requireCordovaModule" to load non-cordova module "fs" is not supported. Instead, add this module to your dependencies and use regular "require" to load it.

Android:

Error installing Cordova plugin: cordova-plugin-ms-adal. The plugin dependency cordova-plugin-compat does not support this Cordova version.



Hi @James Lo ,

Please follow the steps 

1) Download and install Component

2) Go to your application, click on dependency and search for ADALPlugin, ADAuthProvider

3) Install dependency 

I have provide image, i did not get error after install dependency. Do you want to do same or different. Kindly update here

Azure.jpg

happen the same issue when i build the apps with MABS 7.1. 

Could you advise how to fix it ?! 

  • Error: Error installing Cordova plugin: cordova-plugin-camera. Due to security concerns, the required dependency for the 'q' node module in a plugin hook was missing. For more details, check the product documentation on how to ensure your plugins node dependencies. 


  • Error: Couldn't install the Cordova plugin cordova-plugin-ms-adal. Using "requireCordovaModule" to load a non-Cordova module "fs" is not supported. Add this module to your dependencies and use the regular "require" to load it.
Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.