Cannot edit SMTP Configurations
Question

Hi all,

I have successfully configured my SMTP settings on Service Center and applied changes on the Factory. I am also able to send emails successfully.

Now I want to use other SMTP server so I tried editing the configurations but it doesn't get saved and the old configuration remains.

Am I only allowed once to configure the SMTP settings for a PE?

Thanks,

Gab

Solution

Hello Gab

In my understanding you are free to update the SMTP and it should work fine. Maybe the new SMTP is not getting saved because of some error! 

Please refer this forum initially started for SMTP configuration - https://www.outsystems.com/forums/discussion/11645/how-to-send-emails-from-your-personal-environment/

Hi Manesh,

Upon my observance and a little trial and error, I have successfully used the new SMTP server I set since I don't have any error logs on my module that sends the email and have received test emails from that module.

But I don't understand why the old settings retained on my SMTP Configuration which is somewhat confusing. Please see below screenshot for your reference.

SendinBlue SMTP was my "old SMTP Server" setting.

I am now using SendGrid SMTP to send test emails but here's my recent screenshot of my SMTP Config:

I don't know if it's a bug. Should I open a case on Support?

Thanks,

Gab

Hello @Gab Globio 

I changed the smtp configuration and works as expected. (personal and enterprise env)

If you are still facing the issue, check servicecenter if there's any error logged, if not open a support tichet in order outsystems can check what's causing this issue.

Regards

Gonçalo Almeida

Yes, it works fine. We can update the SMTP and it works fine. If not working for you or having any issues you can open Support Ticket. 

You can also try the new SMTP with some device to test if that's work fine. Might be it has some error and not getting proper authentication! 

If the details are correct and still not saving / updating in Service Centre. You can open a Support Ticket. 


Please feel free to ask if you have any more questions :) 

Thank you for your response @Manish Gupta and @Goncalo Almeida.

It is also working as expected on my end. I just don't understand why my new settings is not reflecting on SMTP Config as I've provided on my screenshot.

Anyway, I'll try to get in touch with the support to understand what's causing this issue.

Thanks again! :)

Good to hear :) You're welcome  

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.