Communication error: There was an error connecting to [host]
Service Studio Version
11.10.22 (Build 42083)
Platform Version
11.10.2.26371

Hi all,

Since last Friday I keep getting an error "Communication error: There was an error connecting to [host]" for multiple applications I manage. I get these errors on at least three independent servers.

The errors are relatively random in that they sometimes occur and sometimes I can still do the action. It happens when:

- Opening application in Service Studio;

- Opening a module in Service Studio;

- Publishing a module in Service Studio;

- Getting data on dev/test in aggregate preview mode in Service Studio;

- Running the debugger in Service Studio;

- Opening dependencies in Service Studio.

Does anyone else get the error? It seems the SOAP calls Studio uses run into timeouts:


Things I have tried (which does not fix it):

- Working on cable instead of WiFi;

- Reinstalling Service Studio;

- Asked colleagues if they have the same problem. One runs on the same Studio version and has no problems. Another on runs on 11.10.21, also no problems.

Attached also the tracelog of the crash. 

Does anyone experience the same problem or know what might be causing it?
A colleague mentioned the firewall, but I find it odd that it works half of the time.

Thanks for any answers!

Regards,

Michiel van Lokven


TracelogServiceStudioErrorOpeningModule.txt

Hello @Michiel van Lokven,

It seems like all the issues point to a problem with your local settings. The following has solved 'strange' connectivity issues for me in the past, so it maybe worth a shot.

1. Rename the folder "ServiceStudio 11.0" to "ServiceStudio 11.0 - BAK".

2. Start Service Studio afresh. This will automatically create a new 'ServiceStudio 11.0' folder in the above directory path.

3. Try connecting to all your environments and associated login information as before (If needed you can reference these from the 'Settings' file in "ServiceStudio 11.0 - BAK" . 

Now try out all the actions as before and see if it helped.

If you still encounter issues, then I would suggest contacting your network team to see if they can assist. Contacting OutSystems Support is always recommended as well.

Regards,

AJ

Champion

Hi Michiel,


I also got the same problem, what AJ suggest is correct (but in my case, I deleted the User Data Folder)

Hi =AJ=,

This worked perfectly, thanks!

Regards,

Michiel

Sadly I was a bit too quick jumping to conclusions. :(  This fix did improve things a bit but I still get the connection errors. Any other suggestions are more than welcome!

Regards,

Michiel

Hi Michiel, sorry to hear that did not work. Did you try Toto's recommendation of deleting the User Data folder instead (after backing it up of course)?

As I had originally suggested, your next option maybe to get help from your network team and/or OutSystems support.

Regards

AJ

Hi =AJ=,

Yes, I have tried. No result sadly. 

However, I did try to work on my mobile hotspot and also I am working at another place, which fixes the problems. This indicates that it's a local internet issue at my home (however directly on cable, the same problem existed there). I will investigate that further.

Thanks for the help so far!

Regards,

Michiel

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.