Cannot request permission to HealthKit using HealthPlugin

Hi all, I'm using HealthPlugin to integrate with iOS HealthKit and having issue when requesting permission to access Health data.

I tried to implement my integration following HealthPlugin Demo but when the RequestHealthAuthorization action ran, the app crashed/exited without any indication of what could have gone wrong.

I believe I have also:

- Passed the correct data to the action which is "resp_rate" string.

- HealthKit enabled in the provision file for the app.

- CheckHealthPlugin action of HealthPlugin did return True.


I'm using iOS 14.4.2 to test and HealthPlugin 2.0.3

Hello Mai

Have you tried Debugging the application with Breakpoint at mentioned RequestHealthAuthorization action? 

Hi @Minh Mai,

You stated that the app crashes 'without any indication', but please confirm if you have checked the ServiceCenter logs as well. If you still need help after reviewing logs, please do share the log information.

Regards

 AJ

Hi Manish,

I tried to debug, but whenever the code execute the RequestHealthAuthorization, the app crash then debugging also stop

=AJ=,

This is the log from ServiceCenter. This is logged at the time the crash happen


Thanks @Minh Mai,

Did you check why NSHealthUpdateUsageDescription is ""? Looks like it is expecting a value.

I have never used this plugin but am hoping the service center log will guide you and other community members to a possible root cause.

Regards

AJ

Hi =AJ=,

I believe this property is in info.plist of an iOS project. Since OutSystems compiled the code behind the scene so I couldn't see the file anywhere. I'm trying to find a way to provide value to it but haven't got any luck.

Are you aware of how to do this?

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.