Issues publishing up to date DLL
Question
Service Studio Version
11.10.16 (Build 40208)
Platform Version
11.12.0 (Build 29969)

Hey there, I am attempting to publish my own Extension in order to interact with SFTP on a server. Origionally we were using https://www.outsystems.com/forge/component-overview/32/sftp however it was using a very outdated version that did not support the key exchange method that i wanted. I went to https://github.com/sshnet/SSH.NET/ , got the latest 2020.0.1.0 DLL and i attempted to create an extensio to wrap it using the "Import Action from .NET assembly".

I have made a few of these methods along with one that returns the Version of the "Renci.SshNet" assembly it is using. Every time i deploy this extension, it keeps using a 2016.1.0.0 version of the DLL.

I tried to change the file name and it is not even using that file when i explicitly only include that DLL and no other one within the Resources folder of the Extension.

I've also tried on a completely empty Personal Environment and it was still happening. The weird thing was that with the extension with the renamed file which i called "Renci.SshNet.2020.0.1.0.dll", the Bin2 folder contained both the outdated DLL and the file i wanted to load and also using the exact same name did not override with the updated version.

(This extension loads Renci.SshNet.dll despite not being included in this module, this still occurs on a completely fresh Personal Environment and a completely fresh Extension with no other mention of Renci.SshNet.dll)



I've uploaded the oap containing the module but i just cannot find anywhere anybody who has had this issue. Origionally i just tried to update the DLL in the sftp forge component and republish which also did not work.


Any help would be appreciated, thanks.

rSFTP.oap

Hello @Blane Thompson,

In Visual Studio, what is the path and version you see for Renchi? For e.g. I published your oap and here's what I see:

Also I did not understand the part about the extension not using Renchi. Does your extension actually need it? Just curious.

Regards,

AJ

Sorry if I didn't explain it well. Renci.Sshnet.dll was in the Source/Bin folder and was 2020.0.1.0 however when publishing, any consumer of it would have version 2016.1.0.


I tried renaming the DLL as well however when this happened, yet it still used a Renci.Sshnet.dll even though I had renamed the file and it showed that file did not exist in the Extension in service center

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.