Error executing query
Question

Good morning....

Since 3 month ago my app works perfectly WITHOUT ANY ERROR MESSAGES.... (this small app I don't changed since various months ago, the app has finished)

Since the day before yesterday (8 june 2021) after outsystems upgrade... the app suddenly show error ("Error executing query") in all options.... The top menu (it worked perfectly) now doesn't work... everthing now has error query.... everything in app has bug, damage.

https://personal-tj8adblc.outsystemscloud.com/Vitacora

Please how do I fix that error..... or how do I to know where is located the bug?...

Thanks.


Hi,

please access service center and check on Monitoring tab the detail of your error. You can post here after to get help deciphering it.


Regards


Please..... help me...

Very Thanks you


Error executing query.

eSpaceVer: Id=640, PubId=0, CompiledWith=11.12.0.30002
RequestUrl: https://personal-tj8adblc.outsystemscloud.com/Vitacora/moduleservices/log?clientTimeInMillis=1623444367310 (Method: POST)
AppDomain: /LM/W3SVC/18/ROOT/Vitacora-72-132677353257041832
FilePath: C:\OutSystems\Sandboxes\Q5MNCB015\Platform Server\running\Vitacora\
ClientIp: 201.244.156.250
Locale: en-US
DateFormat: dd/MM/yyyy
PID: 2676 ('w3wp', Started='6/7/2021 8:46:25 PM', Priv=701Mb, Virt=2115937Mb)
TID: 124
Thread Name:
.NET: 4.0.30319.42000
Client Runtime Packages: client-runtime-core= 3.9.2;client-runtime-view-framework-react= 2.10.4;client-runtime-widgets= 2.10.4;
Client-Side Log

DataBaseException: Error executing query.
at Object.s [as getException] (https://personal-tj8adblc.outsystemscloud.com/Vitacora/scripts/OutSystems.js?oay51q5QPx9P8Xmw2HkooQ:2:10083)
at c.onSuccess (https://personal-tj8adblc.outsystemscloud.com/Vitacora/scripts/OutSystems.js?oay51q5QPx9P8Xmw2HkooQ:3:6054)
    at XMLHttpRequest.<anonymous> (https://personal-tj8adblc.outsystemscloud.com/Vitacora/scripts/OutSystems.js?oay51q5QPx9P8Xmw2HkooQ:3:1470)

If you run the Aggregate/Advanced SQL in the studio can you get results?

Can you also see the data in the database through studio?

Was the database created directly by studio or was it integrated from another source?

Hi,


If you using an Advance SQL, to execute your query, you follow the below-given instructions to debug the issue.


Test your query in AdvanceSQL by clicking on the Test button and check if you are getting your desired output or getting the same error.

a) In case of an error first of all check, your query if it's correct or not.

b) Check the output of your query, an entity should either match with the table you are querying on or it can be a structure with the same attributes (any mismatch with the number of attributes in the structure and the output of the query will give this kind of error) your query will provide as an output.

c) Check the value of input if you are providing any within the query, as the unexpected value used as filter/condition while querying the database with AdvanceSQL may also give such error at run time.


I hope this might help to resolve the issue. If not please provide more details as asked by Jose in the above comment.


Thanks

What upgrade you made?

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.