[Human Readable Change History] Issue with SQL Reserved Word
Question
Forge component by Johan den Ouden

I've found something in the latest version.

When you have a column name (Attribute) called e.g "Key" it's starting return error because the "key" is a SQL reserved word.

I've tested that when debugging here the values I got.


I've added the brackets to escape the reserved word e.g [Key] and worked.

Do you guys have any plan to solve it in a near version?


Thanks,
Paulo


Hi Paulo,

I tried the same in my personal environment and got this error, when we try to pass value normally,

But for reserved Keywords, if values are enclosed within Backticks it results in Proper Output. 

URL : https://saravanan-gamechanger.outsystemscloud.com/TEST/TESTINPUTS?_ts=637607941598567588

Please add a check if the Reserved SQL keyword is found, enclose them in backticks.

Regards,

Saravanan Santhanam.


Hi Saravanan, I think you miss understood my question.

I know how to solve. I'm asking if the people how developed that have any plan to fix that ASAP.

Cool. Hope your issue  will be addressed immediately by the team. 

Happy Coding

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.