Error closing transaction to database


    Hi All,

    I have trouble testing advance SQL queries in the service studio,Have anyone came across this error? Also this doesn't happens for all queries


Hi Naren,

"Error closing the transaction to the database" may occur when Outsystems is attempting to execute a query in the Outsystems database itself and also at many times when we will access other SQL environments like on Amazon, but in other regions .

To resolve this issue you need to forward this to your Environment Infrastructure team. They might do some firewall changes like increasing a timeout. They may need to increase the timeout using below steps :
Configuration tool -> Database section -> Advanced settings to increase "Connection timeout" value.  

You can find more detail about Configuration tool here https://success.outsystems.com/Documentation/11/Reference/Configuration_Tool

Also if  you need to learn more about Outsystem Transaction you can use below links:

https://www.outsystems.com/forums/discussion/2830/transactions-in-the-outsystems-platform/

https://www.outsystems.com/help/SErviceStudio/9.0/default.htm#Using_Data/Handling_Transactions.htm

Regards,

Rashmi

Thanks ,We already tried this and it didn't worked for us.

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.