ORA-12537: Network Session: End of file

Hi All,

We have been getting ORA:12537 :Network session end of file everytime we run some specific queries,These queries works well when run on SQL.

Any help is appreciated,we tried altering connection pool and it didn't worked.

We do have capacity of database to allow more connections-It is not running out of connections -No problem with it.




Hi Naren,

I had this issue in the past but I cannot recall correctly what were the measures we took to fix it. I asked around and this might be due to a few things: 

  1. A query timing out, but in that case you should a time out error logged somewhere;
  2. Network instability that can cause a "micro disruption" in the connection and leads to this error;
  3. An issue with the C# driver from Oracle (I think this was the cause for us)

I'd recommend opening a support case since this might need additional configurations or the installation of a newer driver, and for that no one better than our Support Team to help :)


Hope it helps!


PS: Also found this post: https://www.outsystems.com/forums/discussion/59051/ora-12537-when-creating-an-oracle-database-connection/

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.