[CKEditor.Reactive] How to set config for spellchecker to automatically be on on load.
Forge component by Fábio Fantato
Application Type
Reactive

Can you show what the config input would be for enabling spell checker by default?  From the documentation page for ckeditor the setting is the following but not sure how to get from that to the text input the ckeditor is looking for.

config.scayt_autoStartup = true;
Solution

Hello Jason,

To my knowledge, once you customize the configuration, you also need to set all other settings yourself in the config file. (if there are other ways, then I just don't know yet). So if you are ok with customizing all your options then here's how:

1. In your module, double click on the 'Config' property for the CKEditor

2. Copy paste the config information from the Demo module available in the Forge (or from another source if you have one). For your convenience I am sharing my version of the Config settings so you can customize it as you wish:

"toolbarGroups: [
        { name: 'document', groups: [ 'mode', 'document', 'doctools' ] },
        { name: 'clipboard', groups: [ 'clipboard', 'undo' ] },
        { name: 'editing', groups: [ 'find', 'selection', 'spellchecker', 'editing' ] },
        { name: 'forms', groups: [ 'forms' ] },
        { name: 'basicstyles', groups: [ 'basicstyles', 'cleanup' ] },
        { name: 'paragraph', groups: [ 'list', 'indent', 'blocks', 'align', 'bidi', 'paragraph' ] },
        { name: 'links', groups: [ 'links' ] },
        { name: 'insert', groups: [ 'insert' ] },
        '/',
        { name: 'styles', groups: [ 'styles' ] },
        { name: 'fonts', groups: [ 'fonts' ] },
        { name: 'fonts-size', groups: [ 'fonts-size' ] },
        { name: 'colors', groups: [ 'colors' ] },
        { name: 'tools', groups: [ 'tools' ] },
        { name: 'others', groups: [ 'others' ] },
        { name: 'about', groups: [ 'about' ] }
    ],

removeButtons: 'Iframe,ShowBlocks',

extraPlugins: 'wordcount,notification,font,colorbutton',

wordcount: {
    showParagraphs: true,
    showWordCount: true,
    showCharCount: true,
    countSpacesAsChars: true,
    countHTML: false,
    maxWordCount: -1,
    maxCharCount: -1
},
disableNativeSpellChecker: false,
scayt_autoStartup: true
"

3. The last 2 lines of code above will enable spell check for you on load. These 2 lines of code work well together for me. Based on your own browser settings, sometimes just one of them may do the trick.

4. Publish and run. Spell check is enabled! 

Note: Typically it takes 2 - 3 seconds for the red lines to display.


I hope this solves it,

Regards,

AJ

AJ - Thank you!  That was what I couldn't figure out - your solution works.

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.