New User and Debug operations

New User and Debug operations

  

In a bit of a bother with the debug mechanism. I can't get it to work. Following through the "how-to" videos and landed on Debug video and whichever way I try the app simply locks up. Believe Debug is something many would have used in the development process and for a beginner like me I am lost to know how to get this going. Any help will be greatly appreciated.

Areas of concern.

1). The application installs in default path (after publish) 
C:\Program Files\OutSystems\Platform Server\running\SalesAssistantDebug.306084599 This path under windows is secured hence should Debug be able to work in such setup.

2). Interrogating IIS Manager, I can see the application pool for OutsystemsApplications is shown to use v2.0 of the .Net Framework. However, on my machine, I have the following shown for .Net in the installed applications


Microsoft .Net Framework 3.5 SP1
Microsoft .Net Framework 4 Client Profile
Microsoft .Net Framework  4 Extended
Microsoft .Net Framework  4 Multi Targeting Pack

If I try to reset the Application pool to v4.0 the 1CP and Run fails so I reverted these settings to what they were before.

3). On Firewall settings as suggested in another query about failures in debug, I have added the Outsystems applications as allowed applications withing firewall settings but still no joy.

Thanking you in advance

 

* Have you tried deploying to another machine and debugging against it?
* Are you sure that your server is not in "Production Mode"?
* What errors/problems are you having when you try debugging?

J.Ja
Hi Albert,

I'm sorry that you are actually experiencing such problems. If Justin's questions don't shed a light on the subject, I'm also going to ask, just for troubleshooting it a bit further, if it also happens when you completely disable Windows' firewall.

If none of this helps, I strongly encourage you to send an e-mail to our support department directly from Service Studio's submit feedback, since it also sends some info on your system, so that they can get in touch with you directly and troubleshoot your specific scenario directly with you. They're definitely better equipped to know where to look for.

Let us know how it goes.

Regards,

Paulo Tavares

Have sent through the logs as suggested. Checks so far are as below, haven't got another machine handy (ample ram) to test a different system


My environment is outsystems community edition. The platform server also resides on my local machine. Errors reported to do with connecting to http://localhost but as I mentioned a normal site view is fine, only in debug mode are these errors being encountered.

Checks

machine details

Microsoft Windows [Version 6.0.6002]

Firewall disabled

Antivirus disabled

Application server in "Development Mode"

Preference settings

1). Complete a check of a normal run of the espace using 1CP and browsed the application. Runs OK

2). Run a Debug for the espace using F6. At this point I am ready to access server, go to open in browse and login using this session (logged out from item 1 above)

The application simply hangs after I click on "open in browser". It appears like it is waiting to load the page but eventually the service studio fails with a connection timeout.

Error Dialog

"An error was raised by the application: CompanyView permission required

First time to see this error following the disabling of the firewall and antivirus, hence my query has taken a different route now since this was not initially being flagged.

Have enabled permissions of the CompanyEdit to a tick for the CompanyView page/screen. and rerun the Debug.

Further errors

--------------

Safari can’t open the page "http://localhost/SalesAssistantDebug/" because the server where this page is located isn’t responding.

On seing the above error, I have tried to connect to the service center from within the studio and this has hang the application. The service Studio gone in a loop showing the connection error dialog multiple times before the application is terminated by the OS.

Sounds like you have a bug in your application that *is* making it get to the debugger, but it may not be obvious where the execution is held up. I would try ensuring that the user you are running as has that permission and then seeing if the debugger gives you problems.

J.Ja
Hi Albert,

Are you by any chance running a Home Premium edition of Windows? This edition limits the number of concurrent HTTP connections to IIS to a maximum of 3. So if you're attempting to debug an espace and open it in the browser, you most likely hit this limit, since both the web browser and the Service Studio will create one or more connections to IIS for the debugger. I had a variant of the problem as you describe (my browser locked up as soon as I got to a breakpoint I had set in Service Studio), but after upgrading my Windows edition to Ultimate the problem was solved and debugging works perfectly now.

This problem has been discussed on the forum last year. That's how I found my solution:

 Windows Vista/7 IIS Concurrent Connection Limits

Hope this helps,

Peter
Peter,
Thanks for pointing this out. I have, today managed to access a Vista Professional edition machine, and installed OS. The initial run of Debug did fail with connection error to localhost, but after changing the timeout in preferences from default of 30 seconds to 300 seconds all worked fine. Will advice Support team who have been troubleshooting this with me as well on current status.

Thanks all for your coments and directions here.

Onwards and Upwards....
Thanks Peter for helping Albert out on your first post! That's not a common occurrence for first posts, so it's much appreciated :) Welcome to our community forums!

Albert: I'm glad you sorted it out with our help. Let us know if something else comes up!

Regards,

Paulo Tavares
Ah well, as they say: you never get a second chance to make a first impression :-)

Glad I could help out Albert,

Cheers,

Peter