[FullCalendar Reactive] FullCalendar Reactive displaying default time that not exist in entity record.
Forge component by André Cabral
Application Type
Reactive

How to get rid of this default time, I don't know if this is a default display or not but those times did not even exist in the entity record. I've been trying to configure it but it won't work. I know I am missing something but I don't what it is.


Regards,
Mobarak Dimalotang

mvp_badge
MVP
Solution

Mobarak,

Check my reply above regarding the time difference you see between your entity data and what is displayed on the Full Calendar Reactive.

Unless you are working in an on-premises environment, your OutSystems server's timezone is always set to UTC, and your applications always display date and time in the device's timezone. Timezone adjustment between client and serve is done automatically by the platform.

Hi,

Please check once in its properties. You will get it.

Kind Regards,

Ajit.

what properties, I tried to check my attribute in Entity. the data type was Date Time and also the attribute in Structure was Date Time too. I tried changing the Date Time format but I think it can't be changed.

mvp_badge
MVP

Hi Mobarak,

I can't really help you much with the Full Calendar Reactive as I don't have it installed nor have the time to check now, but a Date Time attribute holds both a date and a time, so it is possible your entity does store the 8am time part... you can check if that info is on the database by viewing the entity's data (double-click on entity in the Data tab of Service Studio).

If that time info is not on the database, it could be that it is being added by the FullCalendar Reactive component itself (but the underlying FullCalendar.io library does not have any default Time component that I can see in their documentation). Someone with more knowledge of the OutSystems component might be able to shed some extra light here.

Hope this helps!

Hi,

change datatype as "Text" for Date and then you can try.

Regards,

Ajit.

Hi Jorge,

the data type of my Attribute in Entity was Date and Time, also in the Structure too.
Those time doesn't even exist in my entity table record.


I tried changing the format of StartDateTime and EndDateTime before displaying those records in FullCalendar but the FormatDateTime(dt , text) function won't work and there was an error

Error Message: 'Date Time' was data required instead of 'Text'

Because of those changing the Format, I thought the data type (Text) was changed also.
so I tried to convert it into the Date Time function of TextToDateTime(dt).
When I run those changes, it just displays nothing.

I am not sure what I am missing, Like what you said, hope someone with more knowledge of the component might be able to shed some extra light here.

mvp_badge
MVP

Hi Mobarak Dimalotang,

Your entities do have a time portion on the database according to your picture. It's not the same time showing on the calendar though, because there's timezone "translation" taking place between the server timezone and your computer's timezone (this happens automatically for Reactive and Mobile applications). How did your entity records get created?

Hope this helps!

Hi my friend if you want to hide this date, just add this option in the advanced options of the fullcalendar

displayEventTime: false,

Hi Francisco,

Thank you, it works.

it git rid of the time that displays in the event blocks but it doesn't change the time posted in Weekly or Monthly.

Here it was displayed.

But in my entities, it doesn't post it at the correct time.

i think that this "error" was because the server hour, in my case add 2h maybe due to I'm from Spain. For my part I dont need the hours in my calendar, only the day, so was not really a problem :/

Hi Francisco

I totally get it. It's about timeZone, right?
basically, there was no error on it and it was the default display of it.


Just need to configure the timeZone.

Regards,
Mobarak

mvp_badge
MVP
Solution

Mobarak,

Check my reply above regarding the time difference you see between your entity data and what is displayed on the Full Calendar Reactive.

Unless you are working in an on-premises environment, your OutSystems server's timezone is always set to UTC, and your applications always display date and time in the device's timezone. Timezone adjustment between client and serve is done automatically by the platform.

Hi Jorge,


Thanks, am gonna check it and try to review the documents of the Full Calendar.
since am just a newbie it is a pain in my ass, I'll consider all of this comment as help.

Regards,
Mobarak

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.