[TheRecorder] [TheRecorder] Error generating the mobile
Question
Forge component by Arley Silveira
Application Type
Mobile

Many Cordova errors when generating the Android app. 

:(

Is somebody using this component for Video Capture? If not, how can I record videos? Thank you in advance!

[2021-08-10T20:16:54.391Z] [VERBOSE] [Build] Calling plugman.install on plugin "source/plugins/cordova-plugin-media-capture" for platform "android

[2021-08-10T20:16:54.391Z] [VERBOSE] [Build] Installing "cordova-plugin-media-capture" for android

[2021-08-10T20:16:54.391Z] [VERBOSE] [Build] Dependencies detected, iterating through them...

[2021-08-10T20:16:54.391Z] [VERBOSE] [Build] Requesting plugin "cordova-plugin-file@^4.0.0".

[2021-08-10T20:16:54.391Z] [VERBOSE] [Build] Failed to install 'cordova-plugin-media-capture': CordovaError: Version of installed plugin: "cordova-plugin-file@6.0.2-OS2" does not satisfy dependency plugin requirement "cordova-plugin-file@^4.0.0". Try --force to use installed plugin as dependency.

[2021-08-10T20:16:54.391Z] [VERBOSE] [Build]     at /usr/lib/node_modules/cordova/node_modules/cordova-lib/src/plugman/install.js:526:43

[2021-08-10T20:16:54.391Z] [VERBOSE] [Build] CordovaError: Version of installed plugin: "cordova-plugin-file@6.0.2-OS2" does not satisfy dependency plugin requirement "cordova-plugin-file@^4.0.0". Try --force to use installed plugin as dependency.

[2021-08-10T20:16:54.391Z] [VERBOSE] [Build]     at /usr/lib/node_modules/cordova/node_modules/cordova-lib/src/plugman/install.js:526:43

[2021-08-10T20:16:54.391Z] [VERBOSE] [Build] Version of installed plugin: "cordova-plugin-file@6.0.2-OS2" does not satisfy dependency plugin requirement "cordova-plugin-file@^4.0.0". Try --force to use installed plugin as dependency.

[2021-08-10T20:16:54.460Z] [ERROR] [Build] No scripts found for hook "before_plugin_add".

[2021-08-10T20:16:54.460Z] [ERROR] [Build] Calling plugman.fetch on plugin "https://github.com/apache/cordova-plugin-media-capture#1.4.3"

[2021-08-10T20:16:54.460Z] [ERROR] [Build] fetch: Installing https://github.com/apache/cordova-plugin-media-capture#1.4.3 to source

[2021-08-10T20:16:54.460Z] [ERROR] [Build] Running command: npm install https://github.com/apache/cordova-plugin-media-capture#1.4.3 --save-exact

[2021-08-10T20:16:54.460Z] [ERROR] [Build] Command finished with error code 0: npm install,https://github.com/apache/cordova-plugin-media-capture#1.4.3,--save-exact

[2021-08-10T20:16:54.460Z] [ERROR] [Build] Copying plugin "source/node_modules/cordova-plugin-media-capture" => "source/plugins/cordova-plugin-media-capture"

[2021-08-10T20:16:54.460Z] [ERROR] [Build] Calling plugman.install on plugin "source/plugins/cordova-plugin-media-capture" for platform "android

[2021-08-10T20:16:54.460Z] [ERROR] [Build] Installing "cordova-plugin-media-capture" for android

[2021-08-10T20:16:54.460Z] [ERROR] [Build] Dependencies detected, iterating through them...

[2021-08-10T20:16:54.460Z] [ERROR] [Build] Requesting plugin "cordova-plugin-file@^4.0.0".

[2021-08-10T20:16:54.460Z] [ERROR] [Build] Failed to install 'cordova-plugin-media-capture': CordovaError: Version of installed plugin: "cordova-plugin-file@6.0.2-OS2" does not satisfy dependency plugin requirement "cordova-plugin-file@^4.0.0". Try --force to use installed plugin as dependency.

[2021-08-10T20:16:54.460Z] [ERROR] [Build]     at /usr/lib/node_modules/cordova/node_modules/cordova-lib/src/plugman/install.js:526:43

[2021-08-10T20:16:54.460Z] [ERROR] [Build] CordovaError: Version of installed plugin: "cordova-plugin-file@6.0.2-OS2" does not satisfy dependency plugin requirement "cordova-plugin-file@^4.0.0". Try --force to use installed plugin as dependency.

[2021-08-10T20:16:54.460Z] [ERROR] [Build]     at /usr/lib/node_modules/cordova/node_modules/cordova-lib/src/plugman/install.js:526:43

[2021-08-10T20:16:54.460Z] [ERROR] [Build] Version of installed plugin: "cordova-plugin-file@6.0.2-OS2" does not satisfy dependency plugin requirement "cordova-plugin-file@^4.0.0". Try --force to use installed plugin as dependency.

[2021-08-10T20:16:54.460Z] [ERROR] [Build] Build failed with the following error: Error installing Cordova plugin: cordova-plugin-media-capture.

Dear Carolina,

It seems that the used plugin in the Extensibility Configuration is version 1.4.3, try to use the latest version of the plugin on github. It seems that old version requires old version of cordova-plugin-file plugin.  please make sure that the used version is compatible with file plugin.

Let me know if you need more details

If this solve your problem, mark it as correct answer.

Hi @Carolina Bessa, just published a new version. Give it a try.

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.