[Ultimate PDF] Process cannot access D3DCompiler_47.dll
Question
Forge component by Leonardo Fernandes

Tried using the component to generate a PDF file but unfortunately it keeps on having this error message.

The process cannot access the file 'C:\Windows\TEMP\.local-chromium\Win64-848005\chrome-win\D3DCompiler_47.dll' because it is being used by another process

Anyone else encountered this before and knows a solution?


Cheers

Emman

mvp_badge
MVP
Solution

Emman, could you please update to the most recent release, 4.0.4? You may get that same error once more with the new release, but it should auto-recover from it on your next try.

Hi Leonardo,

Got it and it now works! Thank you for the quick response to the issue!

By the way just to confirm, are we still expecting the same issue to happen and have it resolve with a retry?

Thanks in advance!


Cheers!

Emman

mvp_badge
MVP


Yes, if that issue happens again, a retry will automatically fix it.

The issue happens because the temp folder is periodically deleted by OutSystems, so some of the files required for Chromium to work might be lost. Once we detect the error, the next retry will download and install a new Chromium.

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.