[Health & Fitness Plugin] Error 101, Variable not authorized
Mobile icon
Forge component by Platform Maintenance
Application Type


Im happy to see this kind of plugin available on OS now,

i'm interested to use it and try the demo, but seems its not work well for me.

after selecting the google account, this error appear.

do you have any suggestion to fix this issue?




I have the same error as Roman, no matter which of my google accounts I selected, the same error occurs.


I'm part of the Mobile Ecosystem Team in Outsystems.

Thanks so much in advance for having an interest in the Health and Fitness plugin.

The Android version of the Health and Fitness plugin as a dependency of the google APIs and because of that the developer should setup the application in their google console(see images attached) in order to provide a list of test account until the app is published, make sure the package name of your app is matching the package name field in the image 2. For that reason the permission request screen is not appearing and the app is not requesting all the necessary permissions. 

If you want to test without doing that configuration you can try the ios version of the sample app because doesn't have a dependency on the google APIs, instead of that is using HealthKit.

Thanks so much and let us know if we can help with something more 

Hi Hector,

I'm still getting the same error. It would be great if you could give the configuration process in detail. Thanks!!

I am also having this issue and would like to see some sort of resolution.

Hello Hector,

Your instructions are not clear, and the grammar in your post does not make any sense. Could you have somebody else from the team rewrite some instructions on how to set up a user to have access?


Thanks so much for the feedback, based on that there are some questions related how to setup the plugin and is a little confusing based that there are some important steps we are working in create a video demonstrating how to do the configuration, we will be posting this on the Documentation Page of the plugin.

Thanks so much   

Thank you Hector, please let me know when the video is posted. We will be waiting with anticipation!

Any update here?


As a quick solution for the configuration of the plugin in Android we did this small video as a quick solution for the questions raised. We are working on to have a more clear documentation with each one of this steps well explained, in the meantime please check this video.


Thank you for the instructional video. Quick question: how would you get SHA-1 certification on Windows? I see you are using a command on Mac, but I am not finding anything on how to get this on Windows. Here are a couple things I have tried in the command line:

 C:\Users\matth>keytool -printcert -jarfile C:\Users\matth\Downloads\Test_Progressive.apk

Not a signed jar file

C:\Users\matth>apksigner.jar verify --print-certs C:\Users\matth\Downloads\Test_Progressive.apk

'apksigner.jar' is not recognized as an internal or external command,

operable program or batch file.

On another note, I believe there is a dropdown that shows a nonblurred email address where I think you meant to blur it. 

You can find apksigner tool in the cmdline-tools in the android sdk folder. 

Let us know if there is something more that we can help

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.