[Social Login Mobile] error 403 disallowed_useragent on using Google OAuth with SocialLoginMobile Plugin
Mobile icon
Forge component by Platform Maintenance

Hi all,

I was using the Social Login Mobile component and I am stuck with the google OAuth where I get "error 403 disallowed_userage" error. I found This and came to know that Google has narrowed the OAuth services with the system browser only. Also tested Nico Pineda's suggestion to open a browser inside the device itself. Still, that's not working. 

For those who never used this component before, it's easy to use, configure component that can tolerate many social apps. Feel free to read the documentation.

It will be great if tested and answer this and many of the forum members can use the component without fail.




I have similar issue. Any feedback so far?

Hi Neil Gonzales,

Sorry for the late reply,

you can simply use the In-app browser plugin.

Try implementing this in your app and make sure to use the handler from the layout which is deep-linked, also don't forget to add the extensibility property specified in the demo.

It worked for me.



Rashid - sorry for late replying. I tried to use your suggestion couple of times, hence my late reply. Upon clicking the Google Login, it redirect me to Google chrome and URL is localhost. Sorry if I will ask for your help again. Would you be able to send me some sample up to direct to home page please. 

Appreciate your help.

Are you able to open the external browser and sign in using gmail?

Yes to external browser but to the login page of my app instead of the oAUTH page.

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.