[Social Sharing Plugin] Error in generating android apk
social-sharing-plugin
Mobile icon
Forge component by Experts
Application Type
Mobile

[2021-12-23T04:01:10.093Z] [ERROR] [Build] android:exported needs to be explicitly specified for <receiver>. Apps targeting Android 12 and higher are required to specify an explicit value for `android:exported` when the corresponding component has an intent filter defined. See https://developer.android.com/guide/topics/manifest/activity-element#exported for details.

Here is the error we encounter when generating app for android on MABS 8. May I know how do we address this? Thank you.

Hi Guys,

We also have this error message. 

In the plugin.xml file of the plugin you can see that the "android:exported" attribute is indeed not set; 

<config-file target="AndroidManifest.xml" parent="/*/application">
	<receiver android:name="nl.xservices.plugins.ShareChooserPendingIntent" 
		android:enabled="true">
		<intent-filter>
			<action android:name="android.intent.action.SEND"/>
		</intent-filter>
	</receiver>
</config-file>

Are you going to fix this guys?

Kind regards,

Furkan Çetin

Staff

Hello @Furkan Çetin and @jdpalacios,


There is a new version of the plugin that includes the "android:exported" attribute, and as such is compatible with MABS 8, please check out the new version.


Kind regards,

Experts team

Hello @Experts

Good Day!

We encountered the same issue regarding generating APK in Android in Outsystems development studio. Please see screenshot below: 

May we request a download link for new version of the Social Sharing plugin that includes the "android:exported" attribute, and as such is compatible with MABS 8. As per checking in your previous reply to @Furkan Çetin and @jdpalacios, you didn't indicate the download link of the new version of the plugin. Can you share it with us? 

Your prompt response is greatly appreciated. Thank you very much! 


Best Regards,

Leah

mvp_badge
MVP

Hi Leah,

When I check the Versions tab of this component, I see a version that was uploaded the same day as the Experts' comment, saying its MABS 8 compatible:

Do you have this version installed?

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.