Designing login page

Hi Everyone,
My question is a two part question...
I am designing a login page by dividing the blank page by using two-columns but their is something wrong with the layout structure... since it is not displaying the page on publish

I have attached the service studio design page and the display screen when i am publishing data for reference.. Please look into it 

RevMaxLogin.oml

Solution

Hi saif sheikh,

You have forgot to add the LayoutBlank block into LoginPage. I have updated the oml please check.

On other note, Please make LoginPage screen accessible to anonymous role.

I have also done some changes to Login screen to match your requirement, have a look. If it is ui changes you can modify the login screen so that rest of the functionality can be reused. 

Thanks
Pankaj

RevMaxLogin.oml

Hi Pankaj,
Thank you for your swift reply. Could you suggest if its better to design a login page, than to use the pre- defined one?

Hi saif sheikh

You can use existing login page as far as there is no special requirement to have different login page. 

Thanks
Pankaj

Hi Pankaj,
Details of column 2 which is on the right hand side are not getting displayed, when i publish. Could you please check what is causing this issue since their are no errors in the file

RevMaxLogin.oml

Hi saif sheikh,

Please check the URL on the top, you must be opening /LogainPage not /Login.


I have done some changes in the OML, please check.

Thanks
Pankaj.

RevMaxLogin (1).oml

Hi Pankaj,
Downloaded the .oml file you have sent but the details of column2 are not visible in display. Also tried to fetch them through Widget tree but it is not showing anything. made sure the url is login page but it is not working..Could you please help
Meanwhile i have been working on tthe attached .oml file but the issue of the column2 not getting displayed still persists.
Would it make any difference if we use only containers inplace of adaptive display columns.. just asking?

RevMaxLogin (2).oml

Hi @Pankaj Jain ,

The issue as you mentioned was with the style classes and since the local variable for input sections was not defined it was not displaying the data.. It is working now.
Thank you for your time.

RevMaxLogin.oml

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.