[Oracle Connector - P11] Problem running Oracle function
oracle-connector-p11
Web icon
Forge component by Eduardo Oliveira
Application Type
Traditional Web

Hello guys

I was able to invoke an Oracle Stored Procedure but I'm having trouble using this component to invoke a function.


it's a simple function with a varchar2 input parameter and a varchar2 output parameter.


Getting the following error:


And this is how I'm using it:

Can anyone help?


Thanks


JM

Further info:


If my Oracle function has no input parameters, it works and I get the output parameter.


Anyone?

mvp_badge
MVP

Hey José,


The error says your input is receiving more characters than it can hold.

So, or the value you are passing is bigger than the available space in the input in the PL/SQL (and assuming it's the input and not the output), I would sayyou could test with a single character value to see if it works.

It can also be the conversion that you seems to be doing (ToObject) is not correct or should not be done at all (but I didn't find any documentation or examples on how to use it).

I also am looking around to see if anyone already used it the way you are trying to use and can give a hand here.

Hello Eduardo

Thanks for the help. I've tried with different values, including 1 character only. all to the same result. I understand the error (it's an Oracle error) and it happens, like you said, when we try to enter a larger amount of characters than what the column holds or we're dealing with a conversion issues. That doesn't seem to be the case here.

The "ToObject", the component is expecting that, from what I can gather. The few examples I've seen always use that conversion. I opened the component in Integration Studio and the data type is indeed object.



Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.