How to NOT specify Value and Label for charts when using Highcharts JSON
Application Type
Reactive
Service Studio Version
11.14.14 (Build 59923)

Hi,

I have used Highchart Stacked Column Chart, and it works fine. The issue is that the labels on x-axis are also picked for the "Label" option of the chart, and also from the Highchart JSON. (image attached for both and chart as well). I only want the stacked one, not the other two on the right, but don't know how to NOT specify them in the "Label" parameter so that the chart only picks categories from the JSON passed.

I cannot set the Label and Value as null, it gives me error. 

I currently have static data (making this for the first time), hence I have manually added the categories but only one in array. (below is that highchart JSON)

"title: {
        text: 'Ageing'
    },
    xAxis: {
        categories: ['Mar-22']
    },
    yAxis: {
        min: 0,
        stackLabels: {
            enabled: true,
            style: {
                fontWeight: 'bold',
                color: ( // theme
                    Highcharts.defaultOptions.title.style &&
                    Highcharts.defaultOptions.title.style.color
                ) || 'gray'
            }
        }
    },
    legend: {
        align: 'right',
        x: -30,
        verticalAlign: 'top',
        y: 25,
        floating: true,
        backgroundColor:
            Highcharts.defaultOptions.legend.backgroundColor || 'white',
        borderColor: '#CCC',
        borderWidth: 1,
        shadow: false
    },
    tooltip: {
        headerFormat: '<b>{point.x}</b><br/>',
        pointFormat: '{series.name}: {point.y}<br/>Total: {point.stackTotal}'
    },
    plotOptions: {
        column: {
            stacking: 'normal',
            dataLabels: {
                enabled: true
            }
        }
    },
    series: [{
        name: 'Less than 3 months',
        data: [2846]
    }, {
        name: '3 to 6 months',
        data: [47]
    }, {
        name: 'Greater than 6 months',
        data: [2]
    }]"

The graph :

Hi Aman,

As a workaround you can assign a  dummy aggregate/ list that doesn't have any value  So that the chart can render only with the assigned JSON on HighChartsJSON

Best Regards

Devendra

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.