SQL primary filegroup full!!

SQL primary filegroup full!!

  
Hi All: 

I am getting this message when I try to compile my espace. It says that the primary filegroup is full. I have plenty of space left in my C Drive. Can someone give me the step by step to set the autogrow to on for the 2005 SQL version that comes with the community version of outsystems? Im desperate here.

Julius
Hi Julius,

You can select the database properties



And on the Files page select the data file and choose unrestricted growth.



If it's already unrestricted maybe you've hit the Sql Server 2005 Expres limit of 4Gb per database. More info here at the end of the page.
You can check database size on the General page of the database properties:



Let us know if this helped.

Best Regards
David Nunes
Hi devid

its working for me when i done this change in my database,but my company has 100 branches and all database have same problem but if i do this changes on all database is that gonna harm my head office server
or it will be have any problem 
Hello Vishal

Usually the transaction log growth is something that can growth if uncheck, so I recommend properly setup maintenance plans to control the size of the transaction logs.

For instance:  If the problem is the database data files, then you need to size your databases according to the estimated data growth rate. If you're hitting on the 4GB database limit of SQL Server Express 2005 or 2008, then you either reduce the database set, or have to get some SQL Server licenses ...

Hope this helps to define an approach for large number of database instances.

Cheers

Miguel Simões João
Thanks Miguel but one another problem i am facing when i go for sp_spaceused for my database its shows me negative figure in the unallocated space field