Not able to delete records in one section of our app

Hi,


I have tried using the SQL element to delete records that match a user Id and are in the future, the data seems to delete for a second, and then the table is populated again. This would suggest that there is some sort of unseen exception happening, so the data rolls back, but I have tried this in a variety of different ways.

I have tried deleting based just on the user Id. Tried hard coding the parameters for a test. I've tried moving the logic to a new action. I tried using the inbuilt Delete call on the database and looping through data. I've tried hardcoding parameters on the built-in delete call.

For some reason I can't seem to identify, these don't work and the data isn't being deleted. This is odd as data gets deleted from the same table in another process we have.

Hope someone can help. I've attached a screenshot of the original SQL call.

Thanks


Hi Joel,

Have you take a look at logs in Service Center. 

If there are errors (eg. exceptions) so you can check the logs there and get some idea. 

If still not get what error saying you can post it here then people will help.

Regards,

Khuong

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.