Cannot build APK due
Question
Application Type
Mobile

Hello all,

When I tried to generate APK I receive the follow error:

Someone have an idea?

Many thanks, Paulo Torres

Hi,

Earlier in Android application can add any external/library plugin dependency using the 'implementation' keyword, but in later versions it require to use keyword 'compile' to add a dependency.

So now in above error you are referring a  plugin from github.tony19.... This error is saying that in this plugin they used 'implementation' keyword instead of 'compile' word.

Solution : First you should check latest version of this Git repo and update the URL with latest one in your plugin. If latest version also not solved your problem then you need to compile the plugin yourself with latest gradle.

regards

HI vikas,

Thanks for your answer. The resource from Git not solve the problem.

Only way to fund this is checking file by file, right?

Thanks, Paulo Torres

Yes, If there is not any latest version available or latest version not solve the issue. Then only possibility is to create clone of git repo then compile it with correct options. By this way you will get your version of this plugin. But it is going to be time consuming task. So better will be find some alternate of this plugin/library.

regards

Thanks. The files I have in resources of my eSpace. Will be a time consuming to find this word in this amount of files.

Thanks :)

No. I think don't need to find it in entire espace. You just need to check the dependencies used in your project. Any one plugin/dependency refers https://github.com/tony19/logback-android:1.1.1.9

As I mentioned earlier you need to replace it with the latest version of this library. As I can check on the GitHub page of this library there is one more recent version is available. You just need to use that version in your application.

https://github.com/tony19/logback-android



 

could you download and provide log file here. Need to download this from service center. Service Center -> Factory -> your mobile application -> distributions tab -> then download log file for Android build. regards

Many Thanks for helping :)

AndroidBuildLog.txt

Hi Paulo,

From log file also found same reason of failure.

The build phase failed to complete!

[2022-07-17T22:11:00.030Z] [ERROR] [Build] Reason: There was an issue generating the app. Gradle now requires you to declare dependencies using "implementation" or "api" instead of "compile". The dependency being incorrectly declared is "com.github.tony19:logback-android:1.1.1-9". Check your plugin configurations and try again.

So basically you need to find out the plugin which have reference of this GIT repo and then update the Github URL with latest version in the plugin. Then refresh the dependency in your application and you are good to go.

regards

OK. I need a repository in GIT, right? I have the files on my side.

okay, if you have plugin in your source code only, then suggest open this zip file and I think this zip is referring git some where. You  need to update the URL there.

Please help to share this zip file with me. I will try it at my end.

regards

There is a lot of files, some hint to find? I can't share here but I'll put in WeTransfer

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.