facing issue deploying application

Hi everyone, 

i am trying to deploy my application but these outsystems dependencies are not allowing me to. i tried too refresh using manage dependencies in my module but unfortunately it is not working . could any one please suggest the solution. 

mvp_badge
MVP
Solution

Hello again Saif,

They are indeed part of the deployment plan in place, because LifeTime detects that your application have those dependencies. And since those apps are not in the target environment, LifeTime adds them automatically to your plan.

In the image above, you can see the "Fix errors in selection" column where you have several options.

Instead of "Do Nothing", you should select the deploy option for you current version (1.0) for each of those apps. After that, you should revalidate your plan. It should be all green after that. That means that you are good to go :)


Kind regards,

Rui Barradas

mvp_badge
MVP

Hello there Saif,

Hope you're doing well.

As I can see, there's nothing wrong in that deployment plan.

Your application is consuming 3 apps that work as libraries (OutSystems UI, OutSystems Maps and OutSystems Charts). Therefore, there are dependencies between your application and those 3 apps. Your application depends on these 3.

Since they exist in Development Environment, but they don't exist in Non-Production Environment yet, LifeTime is requiring you to include them in your deployment plan, otherwise it will lead into broken references.

Is there a particular reason why you don't want to migrate OutSystems UI, OutSystems Maps and OutSystems Charts from Development Environment to Non-Production Environment? There's nothing wrong with that :)


Kind regards,

Rui Barradas

Hello Rui,

I was assuming they are part of the deployment plan in place. Could you confirm how I can include them since I am not intentionally keeping them out.

mvp_badge
MVP
Solution

Hello again Saif,

They are indeed part of the deployment plan in place, because LifeTime detects that your application have those dependencies. And since those apps are not in the target environment, LifeTime adds them automatically to your plan.

In the image above, you can see the "Fix errors in selection" column where you have several options.

Instead of "Do Nothing", you should select the deploy option for you current version (1.0) for each of those apps. After that, you should revalidate your plan. It should be all green after that. That means that you are good to go :)


Kind regards,

Rui Barradas

mvp_badge
MVP

Hello Saif,

Any news regarding this topic? Did you manage to resolve your issue with the deployment plan?

Kind regards,

Rui Barradas

Hi Rui, 

although no versions have been deployed intentionally from my end, it is showing as the changes were made by administrator for outsystems module. it is shwoing changes by administrator and hence broken dependencies.

mvp_badge
MVP

Great news Saif! Thank you for sharing!


Kind regards,

Rui Barradas

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.