CSS not updated

  
Whenever I change (in ServiceStudio) something in a style, not being the main web.CSS, these changes are not always published to the server.
Is there a way to force update of ALL CSS's of an application ?
Replublish won't work ...

Using v6.0, but also experience this in 5.0 and 5.1
It probably happens because of the browser's cache. Maybe this isn't the case, but anyhow, try reloading the page with Ctrl-F5 to ensure that the cache isn't used.
Do you see the CSS version being incremented in the page source? (<link href="/RichWidgets/Blocks/RichWidgets/Private/jQueryUI.css?13832" type="text/css" rel="stylesheet" /> )
I am experiencing the same.

The link is (sometimes) being updated but to no effect.

steps I am doing:

1. update css in for example RichWidgets and then feedback_message.css
2. publish richwidgets
3. update references in espace for richwidgets
4. publish the espace
5. hoping to see the change.

clearing browser cache, looking with "inprivate browsing"

Hello guys,

i've also faced this a couple of times, and i think our team is already aware of this.

The workaround that I use and that solves this, is a bit strange, but does the job, is to create a solution with only the eSpace were CSS won't update, and then publish that solution...


regards,
Miguel
@André / Pedro :
It has nothing to do with the cache. The actual CSS is not overwritten on the server. If you look into the actual source, there's nothing changed.

@Miguel :
Should we do this for EVERY CSS which is not updated ??
That means a lot of additional eSpaces. To me it's a problem of the platform which does not handle additional styles, specific for a webscreen or webblock, correctly

Please OutSystems take a look into this problem, would make life much easier :-)
Hi Joop,

If you have upgraded your system from versions before 5.0 the upgrade might have been conservative and might not have changed the compiler to generate cache invalidation suffixes (like what André was mentioning). Bear in mind that the cache might be server side.

If you believe that is your case (i.e. if when you click view source you don't see the ? with the numbers at the end of  the  static files' urls) then you might want to contact OutSystems support so that they help you enable that.

Cheers,
Tiago Simões
No guys !!
It IS a problem of the platform it self.
It had been in 5.0, had been in in 5.1 and still is a problem in 6.0

Nothing to do with upgrades/updates or what so ever.
Hi Joop,

Sorry, I ended up by not understanding.
When you do view source in the browser do you see the cache invalidation suffixes in static files André mentioned? (Like you see in the view source of this webpage)

Cheers,
Tiago Simões
Hi Joop,

I've been able to replicate the issue and we'll take a look into that.

Cheers,
Tiago Simões
  
I believe that i had same behaviour last friday in a web_screen css.

Work arround : I used the e-Space css, instead creating the style in the web_screen css.
Hi guys,

To pass through this problem please add a dummy URL line into your page CSS.
.Dummy {
    background: #000 url('img/something.gif') repeat-x;
}

A fix for this problem will probably be available in the next release.
Best Regards,

HD
I was experiencing this problem last week also.

On the moment I am working on CSS-heavy screens.
My CSS was placed in de screen.css, my primairy test browser is Chrome but I also tested IE, FF, Safari, Opera.

The behaviour was not predictable: sometimes the changes appeared and sometimes not.

There was css 1 problem that kept displaying the style wrong. At last I send it to support only to hear that they (with exactly the same espace+css) had no problems. They made a clone of the espace and send it back to me.

When I published the clone it worked also. Even weirder: I copy/pasted the part to my existing espace and it worked there also.
Keep in mind that it was the same 'code' and the same css.

I will keep the suggestions above in mind and hope that I will experience no more css issues : )
Hi Hans,

This is a differential compilation problem.
When you switch from a version that has an URL to one that doesn't have, the compiler is ignoring your changes, keeping the old version.
As workaround, either you delete the compiler cache or add an URL dummy element (easy way).

The fix will come out soon. 

Thank you all for helping tracking this.

Best Regards
HD
Just to let you know that the problem still exists in 6.0.1.13.

Yesterday I changed css tags whereby an image was no longer used.
However this image still appeared after publish.
Deleting browser cache and restarting pc had no effect.
I placed the dummy-css mentioned above in the css and it seems now to work.
Hi Hans,

That should have been fixed in version 6.0.1.13 of the Platform Server, (and not Service Studio).
Is that what you are using?

Cheers,
Tiago Simões
No, I meant the latest Service Studio. I will arange an update of the server.