outsystems database constantly being offline, but seems to be ghost offline

outsystems database constantly being offline, but seems to be ghost offline

  
Hi guys,

Are you aware of any SQL job, or activity made by Outsystems Platform that might cause the database to become offline/suspected?

I constantly get an alarm by System Center, saying that the database is offline. It causes no downtime, and if I go to the SQL logs, I get no offline message. What I see is that during the night, there are a lot of messages regarding  CHECKDB running successfuly, and that the database was started. But those messages are at times completely far from the alarm times we get.

It would be helpful to understand what could be causing this, knowing that it causes no downtime, however.
Our version is 6.0.0.9, by the way.

Thanks in advance,
Nuno Silva
Hi,

This is the message I get alot around 05:52.

Date 15-01-2012 17:22:21
Log SQL Server (Current - 14-01-2012 05:52:00)
 
Source spid129
 
Message
CHECKDB for database 'outsystems' finished without errors on 2012-01-13 23:59:32.537 (local time). This is an informational message only; no user action is required.


Date 15-01-2012 15:22:21
Log SQL Server (Current - 14-01-2012 05:52:00)
 
Source spid129
 
Message
Starting up database 'outsystems'.
 

But this seems to be from a job I have configured to run everynight. So it should be ignored.
Hi Nuno,

Are you sure it is related with OutSystems?

There are some SQL Agent Job options related to the DB maintenance and backup, that run checkdb with REPAIR_FAST, and this implies that the DB be in single user mode.

Hope this helps.

Regards,

Nuno Cavalheira Antunes
Thanks on the reply Nuno.

the thing is that I'm not sure of it. Just want to understand why all of this offline alarms I'm getting. I'll move on to SQL troubleshooting as long as I know that the Outsystems platform is not itself causing it (any maintenance plan, outsystems platform might have internally programmed to perform).

By the way, I don't have any maintenance plans running during the day.

It's strange, because no other Databases in the SQL Engine are having this behaviour.

Thanks,
Nuno Silva