Create a link from another server to acess localhost server

Create a link from another server to acess localhost server

  
Hi all,

I have an application created on the server localhost. The application works fine when I enter http://localhost in the browser.

However I created a link (http://aplicacao.pt) on another server to access the localhost server. So when I go to http://aplicacao.com i'm redirected to localhost server but the layout of the application is unformatted.

Can someone explain to me how do I create a link to the localhost server without the layout be unformatted?

best regards
Hello Samuel

Welcome to the OutSystems Agile Network Community, hope you you find and share a lot about working with OutSystems.

I need you to clarify a little bit the kind of redirect you've done. If the application is running on the localhost (http://localhost), how are you redirecting the http://application.pt from another server to this one on localhost?

If the application is showing all unformatted, it's possible that the CSS and JS files are missing. Depending on how you made teh redirect, that might be expected.

Share it with us and I can see if it's fixable.

Thanks

Cheers

Miguel Simões João
Hello,

I apologize for the delay.

I'll try to explain better:

I created an application and deploy in iis. i Acess the application via the localhost ip http://127.0.0.1/ ... . So far everything worked correctly.

However I created a new website in iis to redirect the application. This is because instead of accessing a http://127.0.0.1/  i want access with 
http://aplicacao/ ...

This new site basically contains a file "redirect.html" and a web config.

The "redirect.html" contains
<meta HTTP-EQUIV="REFRESH" content="0; url=http://aplicacao/...">

With this, my problem is that when I enter the site with http://127.0.0.1/ the application appears fine. However When I access through http://aplicação/ ... the css is all unformatted and for example the error feeback messages dont appear formated with the red square and the text is unformated.

In the service center have the default dns as "localhost" and the settings of the application also have everything to localhost.


I really dont know what to do.