Unable to fetch data from Postgresql Table Function

Hello All,

We are using Postgresql external DB for our project. Our outsystems environment is in AWS cloud and Postgresql instance is also in AWS cloud. We have no issues in connecting to database and fetching the data from postgresql db tables. Also we have no issues in calling a scalar functions in postgresql.

The issue we are facing is : we are not able to get data from postgresql table functions (Function returning table as result set).

Here is the screenshot of the error message. 

Please let us know if anyone can fetch data from postgresql table functions.

Here is the function code :


isn't "public" a reserved "keyword"? 

Have you tried to enclose it with 'quotes'? 

Kind regards, Markus

It is not a reserved word in postgresql and it is just the name of the schema.

The same statement works perfectly in pgadmin client tool and return the data :  select * from public.functionname() 

Also i tried removing it and adding quotes but nothing seems to fetch data from DB.

Anyways thanks for your response.

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.